View Issue Details

IDProjectCategoryView StatusLast Update
0000568XdebugInstallationpublic2010-04-21 19:09
ReporterhwoodyAssigned Toderick 
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version2.1.0RC1 
Target VersionFixed in Version 
Summary0000568: How to get rid of annoying "Xdebug requires Zend Engine API version 220060519" message ?
DescriptionHi !

I am trying to install version 2.1.0RC1 from source.

I am doing the following in the source dir

# ./phpize
# ./configure
# make
# make install

and then I add:

zend_extension="/usr/local/lib/php/20090626/xdebug.so"

to php.ini


When then running

#php somescript.php

I see this message:

Xdebug requires Zend Engine API version 220060519.
The Zend Engine API version 220090626 which is installed, is newer.
Contact Derick Rethans at http://xdebug.org for a later version of Xdebug.

How do I get rid of that message ?

Please note I am using Xdebug v2.1.0rc2-dev (from SVN)
TagsNo tags attached.
Operating SystemFreeBSD 8.0
PHP Version5.3.2

Activities

derick

2010-04-21 19:09

administrator   ~0001456

This is not a bug, you're simply building against headers that don't belong to the PHP version that you're running. Please contact the mailinglist for support.

Issue History

Date Modified Username Field Change
2010-04-21 13:59 hwoody New Issue
2010-04-21 13:59 hwoody Operating System => FreeBSD 8.0
2010-04-21 13:59 hwoody PHP Version => 5.3.2
2010-04-21 13:59 hwoody Xdebug Version => 2.1.0-dev
2010-04-21 19:09 derick Note Added: 0001456
2010-04-21 19:09 derick Status new => resolved
2010-04-21 19:09 derick Resolution open => no change required
2010-04-21 19:09 derick Assigned To => derick