View Issue Details

IDProjectCategoryView StatusLast Update
0000640XdebugUsage problems (Wrong Results)public2011-03-30 21:57
ReporterrichAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformx86_64OSUbuntu Linux 2.6.35-22-genericOS Version10.10
Product Version2.1.0RC1 
Target VersionFixed in Version 
Summary0000640: Unable to expand standtart classes in Remote Debugging
DescriptionSee Steps To Reproduce
Steps To Reproduce<?php
$x = array(array((object) array('df' => 4)));
$y = array(array(array((object) array('df' => 4))));
$z = 0;

?>

1. Place breakpoint on $z = 0;
2. Start debugging
Expand all x and y variables

----- $x -----
org.netbeans.modules.viewmodel.TreeModelNode@206e9e1f[Name=, displayName=x] array
org.netbeans.modules.viewmodel.TreeModelNode@5c77f4fb[Name=, displayName=[0]] array
org.netbeans.modules.viewmodel.TreeModelNode@54b58608[Name=, displayName=[0]] stdClass
org.netbeans.modules.viewmodel.TreeModelNode@1b40c938[Name=, displayName=CLASSNAME] string stdClass
org.netbeans.modules.viewmodel.TreeModelNode@3a5a8982[Name=, displayName=df] integer 4
--------------


----- $y -----
org.netbeans.modules.viewmodel.TreeModelNode@3e4f15db[Name=, displayName=y] array
org.netbeans.modules.viewmodel.TreeModelNode@bf7be15[Name=, displayName=[0]] array
org.netbeans.modules.viewmodel.TreeModelNode@29ea179c[Name=, displayName=[0]] array
org.netbeans.modules.viewmodel.TreeModelNode@6026bb93[Name=, displayName=[0]] stdClass
org.netbeans.modules.viewmodel.TreeModelNode@7ce0745e[Name=, displayName=CLASSNAME] string stdClass
--------------
$y variable should have
org.netbeans.modules.viewmodel.TreeModelNode@3a5a8982[Name=, displayName=df] integer 4
too, but it is not


TagsNo tags attached.
Operating SystemLinux minicooper 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux
PHP Version5.3.3

Activities

derick

2011-01-10 21:57

administrator   ~0001641

Could you please provide a remote debugging log of this session (See http://xdebug.org/docs/remote#remote_log on how to make one)

derick

2011-03-30 21:57

administrator   ~0001705

The requested information was not provided. Please re-open if you do provide that information.

Issue History

Date Modified Username Field Change
2010-11-12 09:08 rich New Issue
2011-01-10 21:57 derick Note Added: 0001641
2011-01-10 21:57 derick Assigned To => derick
2011-01-10 21:57 derick Status new => feedback
2011-03-30 21:57 derick Note Added: 0001705
2011-03-30 21:57 derick Status feedback => resolved
2011-03-30 21:57 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)