View Issue Details

IDProjectCategoryView StatusLast Update
0000679XdebugUsage problems (Wrong Results)public2014-03-02 14:20
ReporterhernstAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformlinuxOSCentOSOS Version5.5
Product Version2.2dev 
Target VersionFixed in Version 
Summary0000679: negative line numbers in profile file on some eval()d code
DescriptionFor some evaled code I get negative line numbers for evaled code. This only happens for 34 elements out of 848 logged eval()'d code elements.

The cachegrind file is about 2.9G big.

In the file it looks like:
fl=/xml/iwat/php/links.php(217) : eval()'d code
fn=eval
-1359994128 42
...
fl=/xml/iwat/php/links.php(301) : eval()'d code
fn=eval
-358669609 91
Additional InformationPHP is version 5.2.17 (Zend Server without any Zend Modul loaded)
TagsNo tags attached.
Operating Systemlinux
PHP Version5.2.10

Activities

derick

2014-02-27 19:09

administrator   ~0002684

Do you have a short reproducible script that can reliably demonstrate this issue? I can not reproduce this.

hernst

2014-02-28 10:46

reporter   ~0002731

With PHP 5.4 and latest xdebug (2.3dev) I do not get negative line numbers for eval in the profiler anymore. So this issue can be closed.

derick

2014-03-02 14:20

administrator   ~0002735

Thanks for checking, and I'm closing this issue.

Issue History

Date Modified Username Field Change
2011-04-06 15:53 hernst New Issue
2014-02-27 19:09 derick Note Added: 0002684
2014-02-27 19:09 derick Assigned To => derick
2014-02-27 19:09 derick Status new => feedback
2014-02-28 10:46 hernst Note Added: 0002731
2014-02-28 10:46 hernst Status feedback => assigned
2014-03-02 14:20 derick Note Added: 0002735
2014-03-02 14:20 derick Status assigned => resolved
2014-03-02 14:20 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)