View Issue Details

IDProjectCategoryView StatusLast Update
0000736XdebugUncategorizedpublic2012-03-12 16:54
Reportermateo Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2dev 
Summary0000736: exceptions not shown in cli-server router mode
DescriptionExceptions are not shown when running PHP 5.4 Beta 1's CLI server in router mode.

All output prior to the exception is visible.
Steps To Reproducephp -S localhost:8080 error.php

error.php:
----
<?php
throw new Exception('test');
?>
Additional InformationIf xdebug_disable() is called prior to the exception, the stack trace is shown as normal. Or if the server is running in the normal mode (no router) then the xdebug stack trace is seen as expected.
TagsNo tags attached.
Operating SystemOS X Lion
PHP Version5.4-dev

Activities

derick

2012-02-29 13:14

administrator   ~0001936

I can't reproduce this. Could you please try the latest version of both PHP 5.4.x and Xdebug from github?

derick

2012-03-12 16:54

administrator   ~0001980

Can't reproduce, and no feedback provided.

Issue History

Date Modified Username Field Change
2011-10-20 01:45 mateo New Issue
2012-02-29 13:14 derick Note Added: 0001936
2012-02-29 13:14 derick Assigned To => derick
2012-02-29 13:14 derick Status new => feedback
2012-03-12 16:54 derick Note Added: 0001980
2012-03-12 16:54 derick Status feedback => resolved
2012-03-12 16:54 derick Resolution open => fixed
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized