View Issue Details

IDProjectCategoryView StatusLast Update
0000750XdebugInstallationpublic2011-11-18 15:20
Reportersmaring Assigned Toderick  
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
Platformx86OSWindowsOS Version7 64-bit
Product Version2.1.0 
Summary0000750: failed loading php_xdebug-2.1.2-5.3-vc9-nts.dll
DescriptionI installed ZendServer-CE-php-5.3.8-5.5.0-Windows_x86 on my Windows 7 64-bit and followed the instructions for installing php_xdebug, but I get ...

[exec] Failed loading C\apps\zend\ZendServer\lib\php_xdebug-2.1.2-5.3-vc9-nts.dll

not sure how to debug this

Thanks,
Steve Maring
Tampa, FL
Steps To ReproduceTailored Installation Instructions

Summary

Xdebug installed: no
Server API: Command Line Interface
Windows: yes - Compiler: MS VC9 - Architecture: x86
Zend Server: yes - Install path: C:\apps\zend\ZendServer
PHP Version: 5.3.8-
Zend API nr: 220090626
PHP API nr: 20090626
Debug Build: no
Thread Safe Build: no
Configuration File Path: C:\Windows
Configuration File: C:\apps\zend\ZendServer\etc\php.ini
Extensions directory: C:\apps\zend\ZendServer\lib\phpext
Instructions

Warning: You seem to be using Zend Server, which is known to cause issues with Xdebug. It might work, but you're on your own.

Download php_xdebug-2.1.2-5.3-vc9-nts.dll
Move the downloaded file to C:\apps\zend\ZendServer\lib\phpext
Open C:\apps\zend\ZendServer\etc\cfg\debugger.ini and put a ; in front of the line that says zend_extension_manager.dir.debugger= so that it says ;zend_extension_manager.dir.debugger=
Edit C:\apps\zend\ZendServer\etc\php.ini and add at the begining of the file the line
zend_extension = C:\apps\zend\ZendServer\lib\phpext\php_xdebug-2.1.2-5.3-vc9-nts.dll
TagsNo tags attached.
Operating SystemWindows 7 64-bit
PHP Version5.3.8

Activities

derick

2011-11-18 15:06

administrator   ~0001865

[exec] Failed loading C\apps\zend\ZendServer\lib\php_xdebug-2.1.2-5.3-vc9-nts.dll

Are you not missing a colon after the C there? Please check php.ini for that colon.

smaring

2011-11-18 15:14

reporter   ~0001866

Great catch. Thank you. That fixed it.

derick

2011-11-18 15:20

administrator   ~0001867

All right, closing then (not a bug).

Issue History

Date Modified Username Field Change
2011-11-18 15:01 smaring New Issue
2011-11-18 15:06 derick Note Added: 0001865
2011-11-18 15:06 derick Assigned To => derick
2011-11-18 15:06 derick Status new => feedback
2011-11-18 15:14 smaring Note Added: 0001866
2011-11-18 15:14 smaring Status feedback => assigned
2011-11-18 15:20 derick Note Added: 0001867
2011-11-18 15:20 derick Status assigned => resolved
2011-11-18 15:20 derick Resolution open => no change required