View Issue Details

IDProjectCategoryView StatusLast Update
0000753XdebugUsage problems (Wrong Results)public2014-02-27 19:15
ReporterdingAssigned Toderick 
PriorityimmediateSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformwindowsOSOS Version
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000753: Crash with php activescript
Descriptionwhen i use xdebug to debugging php code in php-activescript,
The xdebug will crash at once.
Steps To ReproduceThe xdebug will crash with php-activescript.(Any version of xdebug,php)
Additional Informationphp-activescript: http://pecl.php.net/package/PHPScript
TagsNo tags attached.
Operating System
PHP Version5.2.6

Activities

ding

2011-11-23 08:00

reporter  

bugreport_00753.zip (146,346 bytes)

ding

2011-11-23 08:06

reporter   ~0001868

the code was attached,
  I have set the windows system global environment variable 'XDEBUG_CONFIG':
XDEBUG_CONFIG="idekey=session_1".
  The 'php-activescript.ini' is the config file like 'php.ini', the xdebug configuration is in it.
  If not use xdebug, the 'project.exe' will running OK, if using xdebug, the 'project.exe' will crash with php_xdebug.dll

ding

2011-11-23 08:14

reporter  

bugreport_00753_code.zip (147,336 bytes)

ding

2011-11-23 08:18

reporter   ~0001869

Visual Basic 6 code, use php-activescript:
build a project1.exe, then run the project1.exe
the 'php-activescript.ini' will active, and the php_xdebug.dll will be loaded, then xdebug will crash.

Private Sub Command1_Click()
  ScriptControl1.Reset
  ScriptControl1.Language = "PHPscript"
  ScriptControl1.AddCode " $hello = 'Running OK!'; "
  Label1.Caption = "Running OK"
End Sub
Private Sub ScriptControl1_Error()
  Debug.Print ScriptControl1.Error.Description
End Sub

ding

2011-11-24 00:59

reporter   ~0001870

the 'debugclient.exe' could connected with the xdebug at starting, but any command will make the crash.(such as 'set_into -i 1')

ding

2011-11-24 02:17

reporter   ~0001871

[receive]470 <?xml version="1.0" encoding="iso-8859-1"?>
<init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file://E:/Project/2011xia/fragment" language="PHP" protocol_version="1.0" appid="4216" idekey="28848500"><engine version="2.1.2"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2011 by Derick Rethans]]></copyright></init>
[cmd]step_into -i 1

then xdebug Crash...
is it fragment fault ?

goodook

2011-12-16 02:47

reporter   ~0001880

I have changed the PHP activeScript code to fix the bug.
everything goes OK.

ding

2011-12-16 02:49

reporter   ~0001881

I have changed the PHP activeScript code to fix the bug.
everything goes OK.

derick

2011-12-16 10:39

administrator   ~0001882

What have you done to PHP activeScript to make it work?

cheers,
Derick

ding

2011-12-18 04:31

reporter   ~0001889

I don't know how i fixed the bug,
Xdebug crash on the PHPscript last branche 5.0RC4 or main trunk,
http://svn.php.net/viewvc/pecl/activescript/trunk/

but not crash on PHPscript branche 5.0 http://svn.php.net/viewvc/pecl/activescript/branches/PHP_5_0/
(many bugs, such as failing import object)

I merge the code about opcode compile and exectue, then bug fixed
---another important issue,
 Exactly?Xdebug does not work on PHPscript any, even the crash bug above has been fixed.
  PHPscript compile the code by 'zend_string_compile' function, but Xdebug only replace the 'zend_file_compile' function. So xdebug not rebuild the OPcode.
  Little changes on the phpscript frag compile function(xdebug or phpscript), will fix this bug.

derick

2014-02-27 19:15

administrator   ~0002693

Closing this out, as I understand that the issue is no longer a problem.

Issue History

Date Modified Username Field Change
2011-11-23 07:40 ding New Issue
2011-11-23 08:00 ding File Added: bugreport_00753.zip
2011-11-23 08:06 ding Note Added: 0001868
2011-11-23 08:14 ding File Added: bugreport_00753_code.zip
2011-11-23 08:18 ding Note Added: 0001869
2011-11-24 00:59 ding Note Added: 0001870
2011-11-24 02:17 ding Note Added: 0001871
2011-12-16 02:47 goodook Note Added: 0001880
2011-12-16 02:49 ding Note Added: 0001881
2011-12-16 10:39 derick Note Added: 0001882
2011-12-18 04:31 ding Note Added: 0001889
2014-02-27 19:15 derick Note Added: 0002693
2014-02-27 19:15 derick Status new => resolved
2014-02-27 19:15 derick Resolution open => no change required
2014-02-27 19:15 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)