View Issue Details

IDProjectCategoryView StatusLast Update
0000754XdebugUsage problems (Wrong Results)public2014-02-27 19:19
Reporterjithuthomas7Assigned Toderick 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformlinux apache on cgiOSOS Version
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000754: xdebug running properly on php files directly inside the webroot
Descriptionall php files which are inside inner folders of webroot doesnt get logged.
Only files which are directly in the webroot eg: public_html/test.php is logged.
and public_html/temp/test.php is not logged when it is run.

actually the version of xdebug in phpinfo() is showing as 2.1.2
Steps To Reproduceplace files in the apache webroot and run the script xdebug produces the log in side the log directory

place php file inside any other folder which is inside the webroot eg: public_html/temp/test.php it wont log those files when run
TagsNo tags attached.
Operating Systemlinux
PHP Version5.3.6

Activities

aeheathc

2011-11-28 18:04

reporter   ~0001875

Same issue here on inmotionhosting "advanced" class dedicated server. No problem on my home server with the same config, though.

jithuthomas7

2011-12-07 18:20

reporter   ~0001876

Is there any conflict of xdebug for php running as cgi.
We have disabled all conflicting modules but still xdebug is only logging files only at webroot level.

derick

2012-03-07 19:47

administrator   ~0001955

Hmm, this makes no sense. The only thing I think of for you to try is to check the output of phpinfo() in a file not in the webroot. Check whether all xdebug settings look okay there.

derick

2014-02-27 19:19

administrator   ~0002695

I am closing this out, as no feedback was provided.

Issue History

Date Modified Username Field Change
2011-11-24 10:39 jithuthomas7 New Issue
2011-11-28 18:04 aeheathc Note Added: 0001875
2011-12-07 18:20 jithuthomas7 Note Added: 0001876
2012-03-07 19:47 derick Note Added: 0001955
2012-03-07 19:47 derick Assigned To => derick
2012-03-07 19:47 derick Status new => feedback
2014-02-27 19:19 derick Note Added: 0002695
2014-02-27 19:19 derick Status feedback => resolved
2014-02-27 19:19 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)