View Issue Details

IDProjectCategoryView StatusLast Update
0000795Xdebug(No Category)public2014-02-27 19:20
ReporterbrilloxAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
PlatformWindowsOS7OS Version64BIT
Product Version2.2dev 
Target VersionFixed in Version 
Summary0000795: x-error appear and disappear
DescriptionBasically when i start to debug, the debugger find an error and siplay the error on screen, but only for less than one second; not enough even to get a screebshot.
Steps To ReproduceI have tried with a corrupted mysqli db connection

Opened up the page that call my db function in debug mode

I am using METBEANS PHH as IDE and Firefox 10.0.2 on a Windows 7 ultimate OS with PHP 5.4 nts and a mysql back end
TagsNo tags attached.
Operating System
PHP Version5.4.0

Activities

brillox

2012-03-15 20:48

reporter   ~0001985

this is my X_Debug config in PHP.ini

[X_DEBUG]
zend_extension=C:\Program\php_xdebug-2.2.0RC1-5.4-vc9-nts.dll
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.remote_mode=jit
xdebug.collect_params=2
xdebug.show_exception_trace=1

derick

2012-03-16 22:02

administrator   ~0001989

What happens after the error disappears? It seems very unlikely that this is a bug in Xdebug, as it just outputs HTML and it's up to the browser to display that.

brillox

2012-03-16 22:47

reporter   ~0001996

nothing, the website page is diplaying; however I had to revert back to PHP 53.10 and X-Debug 2.1.4 because the entire website was behaving in a weird way; now everything is working fine, I suspect it is PHP 5.4 or maybe my code which is not compatible with that version of PHP.

derick

2014-02-27 19:20

administrator   ~0002698

I could never reproduce this. Assuming this was something weird on the browser side and closing this issue.

Issue History

Date Modified Username Field Change
2012-03-15 20:46 brillox New Issue
2012-03-15 20:48 brillox Note Added: 0001985
2012-03-16 22:02 derick Note Added: 0001989
2012-03-16 22:02 derick Assigned To => derick
2012-03-16 22:02 derick Status new => feedback
2012-03-16 22:47 brillox Note Added: 0001996
2012-03-16 22:47 brillox Status feedback => assigned
2014-02-27 19:20 derick Note Added: 0002698
2014-02-27 19:20 derick Status assigned => resolved
2014-02-27 19:20 derick Resolution open => unable to reproduce
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)