View Issue Details

IDProjectCategoryView StatusLast Update
0000080XdebugUsage problems (Wrong Results)public2004-08-02 09:43
ReportermathieuAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000080: xdebug.show_local_vars=1 has no effect
Descriptionxdebug.show_local_vars=1 in php.ini has no effect : error message still not display the "variables in local scope" section.
Additional Informationxdebug.default_enable=1 works.
TagsNo tags attached.
Operating SystemLinux
PHP Version4.3.7

Activities

derick

2004-07-28 16:12

administrator   ~0000157

Works fine here, I need a short! script so that I can try to reproduce it and the exact error message that you got.

mathieu

2004-07-28 16:45

reporter   ~0000158

Last edited: 2004-07-29 09:37

------- Test Script -------
<?
   function a()
   {
      $b = 1 ;

      // It causes an error
      $c = 2 / 0 ;
   }

   a() ;
?>

------- php.ini -------
...
580 : zend_extension="/usr/local/apache/libexec/xdebug.so"
...
1119 : xdebug.default_enable=1
1120 : xdebug.show_local_vars=1
...


------- Navigator message -------
# Warning: Division by zero in /home/mathieu/Www/test.php on line 7
# Call Stack
   @ {main}()
   @ a()

BUT NO LOCAL VARIABLE SECTION
show_local_vars DOES NOT APPEAR IN PHPINFO (neither off nor on value)


Is it enough ?

Mathieu

edited on: 2004-07-28 17:47

edited on: 2004-07-29 10:37

derick

2004-08-02 09:43

administrator   ~0000159

This is not a bug as this feature is only implemented in Xdebug 2. The documentation did not mention this, so that's where the bug was.

Issue History

Date Modified Username Field Change
2004-07-26 12:07 mathieu New Issue
2004-07-28 16:12 derick Status new => resolved
2004-07-28 16:12 derick Resolution open => unable to reproduce
2004-07-28 16:12 derick Assigned To => derick
2004-07-28 16:12 derick Note Added: 0000157
2004-07-28 16:45 mathieu Status resolved => feedback
2004-07-28 16:45 mathieu Resolution unable to reproduce => reopened
2004-07-28 16:45 mathieu Note Added: 0000158
2004-07-28 16:47 mathieu Note Edited: 0000158
2004-07-29 09:37 mathieu Note Edited: 0000158
2004-08-02 09:43 derick Status feedback => resolved
2004-08-02 09:43 derick Resolution reopened => no change required
2004-08-02 09:43 derick Note Added: 0000159
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)