View Issue Details

IDProjectCategoryView StatusLast Update
0000803XdebugFeature/Change requestpublic2019-01-23 19:52
ReporterFrozenFireAssigned Toderick 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000803: Add a setting for defining the error levels that xdebug will handle
DescriptionPlease add a configuration entry which defines a custom error_reporting level for xdebug, such that some error levels can be ignored by xdebug, while still being produced by PHP.
Additional InformationCurrently, xdebug handles all error levels that are reporting in PHP (error_reporting). This is less than optimal, because stack traces are not only unnecessary for user notices and other informational errors, but also highly intrusive. Producing an 8-line stack trace for every notice causes huge problems when user notices are utilized to provide debugging information.

In my case, I have written a library which uses user notices to provide state information in the processing of the file format it handles, when "verbosity" is enabled. This is done so as not to interfere with the output buffer, which could interfere with the function of the user's script.

Because my library produces upwards of several dozen such notices, and xdebug produces 7 of its own lines (stack trace) for each notice, this means that the debugging output is 8x the intended size, and difficult if not impossible to read through.
TagsNo tags attached.
Operating System
PHP Version5.3.10

Activities

derick

2018-01-08 16:42

administrator   ~0004553

Is this still something you would find good to have? Nobody else requested it in the last 5½ years :-)

derick

2018-01-29 21:51

administrator   ~0004586

Ping?

derick

2019-01-23 19:52

administrator   ~0004846

I'm closing this out, as apparently there is no more interest in this feature request.

Issue History

Date Modified Username Field Change
2012-03-23 21:30 FrozenFire New Issue
2016-12-10 09:59 derick Status new => confirmed
2016-12-10 09:59 derick Target Version => 2.6.0dev
2017-12-02 18:35 derick Target Version 2.6.0dev => 2.6.0
2018-01-08 16:42 derick Note Added: 0004553
2018-01-08 16:42 derick Assigned To => derick
2018-01-08 16:42 derick Status confirmed => feedback
2018-01-16 23:22 derick Target Version 2.6.0 =>
2018-01-29 21:51 derick Note Added: 0004586
2019-01-23 19:52 derick Note Added: 0004846
2019-01-23 19:52 derick Status feedback => resolved
2019-01-23 19:52 derick Resolution open => no change required