View Issue Details

IDProjectCategoryView StatusLast Update
0000805XdebugFeature/Change requestpublic2015-02-22 14:30
ReporternnmatveevAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version2.3.0 
Summary0000805: Make debugger's timeout period configurable
DescriptionWhen debugger is enabled it slows down web pages loading speed. It prevents users to have 'xdebug.remote_autostart' option always enabled also. It would be great to make timeout period to wait for a response from the client configurable.

See the same option for Zend Debugger: zend_debugger.passive_mode_timeout (http://files.zend.com/help/Zend-Server/zend_debugger_-_configuration_directives.htm)
Additional InformationRelated thread from PhpStorm community forum - http://devnet.jetbrains.net/message/5455253
TagsNo tags attached.
Operating System
PHP Version5.4.0

Relationships

duplicate of 0000963 closedderick Xdebug wait response from remote client and hang up apache php mod 

Activities

derick

2014-02-27 19:21

administrator   ~0002699

It should instantly timeout if the IDE is not accepting connections.
There were some issues, but they should be fixed with 0000963.

Issue History

Date Modified Username Field Change
2012-03-26 07:34 nnmatveev New Issue
2014-02-27 19:21 derick Note Added: 0002699
2014-02-27 19:21 derick Relationship added duplicate of 0000963
2014-02-27 19:21 derick Status new => resolved
2014-02-27 19:21 derick Fixed in Version => 2.3dev
2014-02-27 19:21 derick Resolution open => duplicate
2014-02-27 19:21 derick Assigned To => derick
2015-02-22 14:30 derick Fixed in Version 2.3dev => 2.3.0