View Issue Details

IDProjectCategoryView StatusLast Update
0000816Xdebugpublic2012-04-23 10:58
Reporterjmcbade Assigned Toderick  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformMAC OSOS X OS VersionSnow Leopard
Product Version2.2dev 
Fixed in Version2.2.0RC2 
Summary0000816: Xdebug 2.2.0rc1
DescriptionXdebug 2.2.0rc1 has a bug that was fixed in xdebug 2.1.x If you are using header("Location: {$location}), the debugger will simply halt and terminate the debug session in PHPStorm. The browser will show the page can not be found. This looks like xDebug - bug 0000532 fixed in [2010-02-27] — Xdebug 2.1.0beta3
Steps To ReproduceIf you are using header("Location: {$location}), the debugger will simply halt and terminate the debug session, terminating the browser session.
TagsNo tags attached.
Operating SystemSnow Leopard
PHP Version5.3.8

Activities

nnmatveev

2012-04-19 05:17

reporter   ~0002061

Related thread http://devnet.jetbrains.net/message/5457450#5457450

derick

2012-04-22 00:21

administrator   ~0002062

This is not enough information for me; can you please provide a short, self-contained script (preferrably < 10 lines) and a remote debugging log (see http://xdebug.org/docs/all_settings#remote_log on how to make one).

jmcbade

2012-04-22 09:52

reporter   ~0002063

I will try to get this done, but please understand that I am also in the middle of a couple of larger projects, so it may not be right away. If I can get to this maybe during our holiday in a week or so, I may be able to put the problem build of xDebug back and generate a log for you. I appreciate your understanding on this.

In the meantime, I hope you can do some testing with the MAC OS Snow Leopard (completely updated), using the native server that comes with OS X, using PHPStorm v3~4 and the RC version of xDebug I am referring to.

I am doing something really very simple using a function like:

function redirect_to($location = NULL)
    {
        if ($location != NULL) {
            header("Location: {$location}");
            exit;
        }
    }

The file name of $location being passed is the name of a local file in the same folder, calling the function like this: redirect("filename.php");

I see it was crossed out in my description, but the behavior looks very much like "bug 0000532 fixed in [2010-02-27]" to me. The debug session just terminated the session and reports disconnecting from PHPStorm in both the IDE and the browser.

Again, our holiday time is in about a week.

Regards,

-John

derick

2012-04-22 12:57

administrator   ~0002065

I don't have a Mac, so I can't test on that. However, the most important thing for me is:

- a short script
- a remote debug log that shows the problem and matches a debugging session for the short script.

without that, I probably can't reproduce it, and hence not fix the bug.

jmcbade

2012-04-22 13:29

reporter   ~0002066

I set the setting: "xdebug.remote_log="/Users/john/Desktop/xdebug.log" and substituted the .so file that causes the error. I can indeed reproduce it using PHPStorm 4.0RC3 (and previous release versions).

Unfortunately, no xDebug log is being created. I have tried a few locations with no resulting log file.

I believe I have provided a code snipit that is adequate to reproduce the error.

I can't be the only in the universe with a MAC and that uses xDebug.

Trying to help you here but I can't seem to provide you with a log file per the instructions on your webpage.

derick

2012-04-22 15:31

administrator   ~0002072

Please try the just released Xdebug 2.2.0RC2, which I believe fixes this issue. I think it's a duplicate of 0000774.

jmcbade

2012-04-22 23:30

reporter   ~0002074

Seems to have resolved this issue. If I see more issues I will report them.

What do you think the time frame will be, an estimation that of course is subject to change, will be the final release date for xdebug 2.2.x?

derick

2012-04-23 10:58

administrator   ~0002080

Hoping to release 2.2.0 on Wednesday.

Issue History

Date Modified Username Field Change
2012-04-18 22:48 jmcbade New Issue
2012-04-19 05:17 nnmatveev Note Added: 0002061
2012-04-22 00:21 derick Note Added: 0002062
2012-04-22 09:52 jmcbade Note Added: 0002063
2012-04-22 12:57 derick Note Added: 0002065
2012-04-22 13:29 jmcbade Note Added: 0002066
2012-04-22 15:31 derick Note Added: 0002072
2012-04-22 15:31 derick Assigned To => derick
2012-04-22 15:31 derick Status new => feedback
2012-04-22 23:30 jmcbade Note Added: 0002074
2012-04-22 23:30 jmcbade Status feedback => assigned
2012-04-23 10:58 derick Note Added: 0002080
2012-04-23 10:58 derick Status assigned => resolved
2012-04-23 10:58 derick Fixed in Version => 2.2.0RC2
2012-04-23 10:58 derick Resolution open => duplicate
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)