View Issue Details

IDProjectCategoryView StatusLast Update
0000858XdebugUsage problems (Wrong Results)public2014-02-27 19:47
ReporterdeathemperorAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformPHP 5.4.3, Nginx 1, Zend StudioOSWindowsOS Version7
Product Version2.2.0 
Target VersionFixed in Version 
Summary0000858: XDebug terminates (or Eclipse loses it?) when viewing variables
DescriptionIt's actually the same as reported here: http://bugs.xdebug.org/view.php?id=797 and here http://bugs.xdebug.org/view.php?id=824

The differences are I'm on Windows 7, and my IDE is Zend Studio 9.0.2.

I've tried this instruction here http://stackoverflow.com/questions/5962060/error-message-unexpected-termination-of-script-debugging-ended-when-debuggi?answertab=active#tab-top and got to install 2.3dev but still the same.
Steps To ReproduceSet a breakpoint
Run script, XDebug stops at the breakpoint
Select 'Variables' tab in Eclipse (or similar in other IDEs?)
'Unexpected termination of script, debugging ended.'
Additional InformationZend Studio 9.0.2
Occur on xdebug 2.2.0 and 2.3dev
TagsNo tags attached.
Operating System
PHP Version5.4.3

Activities

Spacesoul

2012-06-24 22:56

reporter   ~0002269

Last edited: 2012-06-24 22:57

View 2 revisions

Same issue than the one I have reported and others are reporting.
In my case it mostly crashes while viewing some PDO objects retrieved from a database with the standar c mysql api or with symfony doctrine.

Tested my issue with version rc1 and there is no crashes, it works perfectly.
Maybe you can try it also with old versions rc1 and rc2, that will help a lot.

( mine is at: http://bugs.xdebug.org/view.php?id=855 )

deathemperor

2012-06-25 03:35

reporter   ~0002270

yeah I've actually reverted back to 2.2rc and I'm happy with it. Although the same issue still happens, it's very rare.

derick

2012-06-25 18:03

administrator   ~0002277

It would be awesome if you could provide:

- a simple script that reproduces it
- a remote debugging log (see: http://xdebug.org/docs/all_settings#remote_log) that accompanies the script

Or, at least the specific source file where you try to view the variable in.

You do say you're on Windows and are using 2.3dev... where did you get that binary from?

Spacesoul

2012-07-02 07:27

reporter   ~0002317

Since the other report has been closed because it seems to be fixed, I am adding here additional information of the crash that Toshihiro Izumi at Eclipse PDT forums added for an easily way of reproduce the crash bug in Eclipse while trying to view variables.

Toshihiro Izumi information:
-----
http://www.eclipse.org/forums/index.php/t/364075/
It seems that Xdebug cannot return PDOStatement object to its client...even though xdebug_var_dump can handle it...
It is reproducible with WindowsXP + PHP 5.4.4 CLI + Xdebug 2.2.0 as well.

<?php
$db = new PDO("sqlite:test.db");
$db->query("drop table test");
$obj = $db->query("create table test(dummy integer)");
var_dump($obj);
?>
When stepover reached at var_dump line, PDT tried to get $obj, and php.exe crashed.
Event log(Windows):
Application Failure php.exe 5.4.4.0 in php_xdebug-2.2.0-5.4-vc9.dll 2.2.0.5 at offset 0001919c.
-----

The issue seems to be solved with the new version you pointed me Derick, v2.2.1dev here in the original topic: http://bugs.xdebug.org/view.php?id=855

I have however noticed that debug session is lost in Eclipse after a while with the new version v2.2.1dev, but its stable and there is no crashes. It works the same than version 2.2.0rc1.

charlesbanshee

2013-01-10 08:22

reporter   ~0002416

In can reliably reproduce this by simply adding a semicolon to the end of a PHP equals statement like this:

<?= $var; ?>

derick

2014-02-27 19:47

administrator   ~0002712

I am closing this, please reopen (with more information if you can), if this is still a problem with the latest versions of PHP and Xdebug.

Issue History

Date Modified Username Field Change
2012-06-24 07:58 deathemperor New Issue
2012-06-24 22:56 Spacesoul Note Added: 0002269
2012-06-24 22:57 Spacesoul Note Edited: 0002269 View Revisions
2012-06-25 03:35 deathemperor Note Added: 0002270
2012-06-25 18:03 derick Note Added: 0002277
2012-06-25 18:03 derick Assigned To => derick
2012-06-25 18:03 derick Status new => feedback
2012-07-02 07:27 Spacesoul Note Added: 0002317
2013-01-10 08:22 charlesbanshee Note Added: 0002416
2014-02-27 19:47 derick Note Added: 0002712
2014-02-27 19:47 derick Status feedback => resolved
2014-02-27 19:47 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)