View Issue Details

IDProjectCategoryView StatusLast Update
0000878XdebugFeature/Change requestpublic2014-02-27 19:39
ReporterTgrAssigned Toderick 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionwon't fix 
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000878: HTML output breaks when started inside a tag
DescriptionThe fancy HTML display (for var_dump, stack traces etc.) becomes unreadable when it is preceded by an unclosed tag.
Steps To ReproduceEnable pretty stack traces on fatal errors and run this:

<div class="<?php get_class() ?>">Foo</div>

This would create a non-existent method fatal error message with a stack trace table, but since the output starts within the attribute of a HTML tag, the <table> tag does not get interpreted by the browser, and the output becomes unreadable.

Debug output inside a comment or a script tag has similar results.
Additional InformationThis could be avoided by prefxining the debug output with code to close open tags, such as

<div style="display: none">--><script></script></div>

this is normally invisible, not wildly invalid HTML, and breaks out of the most frequent enclosing markup.
TagsNo tags attached.
Operating System
PHP Version5.3.9

Activities

derick

2014-02-27 19:39

administrator   ~0002705

I am not going to change this. If you want to prevent Xdebug stopping your layout from breaking, use the http://xdebug.org/docs/all_functions#xdebug_start_error_collection and http://xdebug.org/docs/all_functions#xdebug_get_collected_errors

Issue History

Date Modified Username Field Change
2012-08-30 16:08 Tgr New Issue
2014-02-27 19:39 derick Note Added: 0002705
2014-02-27 19:39 derick Status new => resolved
2014-02-27 19:39 derick Resolution open => won't fix
2014-02-27 19:39 derick Assigned To => derick