View Issue Details

IDProjectCategoryView StatusLast Update
0000909XdebugUsage problems (Wrong Results)public2014-11-11 19:53
ReporterrulatirAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000909: Cannot get profiler output
DescriptionI cannot for the life of me get profiler output.

PHP is 5.4.9 (*not* 5.4.4, *please* keep the version choice up to date) and Xdebug config is:

Version 2.2.1
IDE Key no value

xdebug.auto_trace Off Off
xdebug.cli_color 0 0
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.coverage_enable On On
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.idekey no value no value
xdebug.max_nesting_level 100 100
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append On On
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger On On
xdebug.profiler_output_dir /tmp /tmp
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart Off Off
xdebug.remote_connect_back Off Off
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable On On
xdebug.remote_handler dbgp dbgp
xdebug.remote_host 127.0.0.1 127.0.0.1
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_enable_trigger Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /tmp /tmp
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 4096 4096
xdebug.var_display_max_depth 3 3

The output dir /tmp is drwxrwxrwt, and df reports that the tmpfs is nowhere near full. The function xdebug_get_profiler_filename() returns the expected "/tmp/cachegrind.out.14669" when the trigger is used. That file however does *not* get written.

Nothing suspicious in Apache logs, and yes, breakpoints do work.
TagsNo tags attached.
Operating System
PHP Version5.4.4

Activities

rulatir

2012-12-13 15:49

reporter   ~0002388

Additional observation: if I change profiler_output_dir to *anything* other than /tmp, then xdebug_get_profiler_filename() starts returning false.

rulatir

2012-12-27 18:38

reporter   ~0002405

Things tried so far that did NOT help:

* upgrading PHP to 5.4.10
* downgrading Xdebug to 2.2.0

rulatir

2012-12-27 18:48

reporter   ~0002406

How many tickets filed by "support agreement" users are there in the queue in front of this ticket right now?

derick

2012-12-27 22:24

administrator   ~0002407

The "support agreement" users are not different from normal users. Remember, this is all a Open Source project run in my free time. You can't require me to look at anything, or even expect to do any work. All tickets will be looked at at some point, in order of my preference. However, I don't have an unlimited amount of free, especially over my well deserved holiday period.

rulatir

2012-12-28 13:04

reporter   ~0002408

Last edited: 2012-12-28 13:11

View 2 revisions

I am not "requiring" you anything, I was just trying to learn what my chances were :)

Meanwhile the issue is resolved. The profiler output does appear, just not where I expected it. Was just systemd's PrivateTmp magic. Google tells me it confuses bloody hell out of people and daemons alike.

derick

2014-02-27 20:15

administrator   ~0002727

Just looking at this again, and found http://danwalsh.livejournal.com/51459.html as well, and then saw that you asked how to figure out what PrivateTmp was enabled or not! I was looking at weather I could show that in Xdebug's output info.

derick

2014-11-11 19:53

administrator   ~0002905

No feedback, and, this is not really an Xdebug problem anyway.

Issue History

Date Modified Username Field Change
2012-12-13 15:13 rulatir New Issue
2012-12-13 15:49 rulatir Note Added: 0002388
2012-12-27 18:38 rulatir Note Added: 0002405
2012-12-27 18:48 rulatir Note Added: 0002406
2012-12-27 18:48 rulatir Note View State: 0002406: private
2012-12-27 22:24 derick Note Added: 0002407
2012-12-27 22:24 derick Note View State: 0002406: public
2012-12-28 13:04 rulatir Note Added: 0002408
2012-12-28 13:11 rulatir Note Edited: 0002408 View Revisions
2014-02-27 20:15 derick Note Added: 0002727
2014-11-11 19:53 derick Note Added: 0002905
2014-11-11 19:53 derick Status new => resolved
2014-11-11 19:53 derick Resolution open => no change required
2014-11-11 19:53 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)