View Issue Details

IDProjectCategoryView StatusLast Update
0000928XdebugFeature/Change requestpublic2015-11-20 18:07
ReportertomaszkrolAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000928: Optionally no resolving symlink
DescriptionWe have a production environment based on symlink.

We are deploying new version of an application to a new directory whose name corresponds to SVN revisions number (in ex. 1, 2, 3) and change symlink 'current' so that it points to the newest code version.

Apache's Document Root is set to: /var/www/app/$app-name/current/

Example:

    /var/www/
             www.example.org/
                             1/
                               index.php
                             2/
                               index.php
                             3/
                               index.php
                             current => 3

When we try to debug the application we encounter a problem with directory mapping, because symlink current is resolved by xDebug to return the real path, for example: /var/www/www.example.org/3/... instead of the expected /var/www/www.example.org/current/...

We made a small modification to xdebug that allows for optional disabling of symlink resolution.
TagsNo tags attached.
Operating System
PHP Version5.1.0

Activities

derick

2014-02-27 19:48

administrator   ~0002713

The symlinks are resolved by PHP internally. Xdebug doesn't have access to the unresolved symlinked directory and filenames. You speak however of a small modification. Would you care to share that one?

derick

2014-05-19 23:17

administrator   ~0002824

The symlinks are resolved by PHP internally. Xdebug doesn't have access to the unresolved symlinked directory and filenames. You speak however of a small modification. Would you care to share that one?

goozak

2015-07-22 14:24

reporter   ~0003155

I'm also seeing this bug when debugging with Komodo IDE 7 & 9. I filed a bug in their system as well (https://github.com/Komodo/KomodoEdit/issues/208).

I mostly added this note to try to 'revive' this bug since it doesn't look like the original reporter tomaszkrol will submit his "small modification" after all... :-)

derick

2015-11-20 18:07

administrator   ~0003251

Closing this out as I don't know what to do about this, and the original reporter didn't provide me with his "small modification".

Issue History

Date Modified Username Field Change
2013-03-01 15:21 tomaszkrol New Issue
2014-02-27 19:48 derick Note Added: 0002713
2014-02-27 19:48 derick Assigned To => derick
2014-02-27 19:48 derick Status new => feedback
2014-05-19 23:17 derick Note Added: 0002824
2015-07-22 14:24 goozak Note Added: 0003155
2015-11-20 18:07 derick Note Added: 0003251
2015-11-20 18:07 derick Status feedback => resolved
2015-11-20 18:07 derick Resolution open => no change required