View Issue Details

IDProjectCategoryView StatusLast Update
0000954XdebugUsage problems (Wrong Results)public2016-11-28 21:10
ReporternaitsirchAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformPHP 5.4.14OSWindowsOS Version7
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000954: Crash when accessing object property in another call stack level
DescriptionI have started PHP's built-in web server. I placed a break point at some code in Netbeans. The debugger has stopped there.
Now when I choose another call stack level (see attached screenshot) and try to view `$this` -> `$config`, xdebug crashes suddenly.
Steps To ReproduceVery Complicated
Additional InformationUsed WinDbg to debug and I got this output:

*** wait with pending attach
Symbol search path is: SRV*"D:\Programme\WinDbg Symbol Path"*http://msdl.microsoft.com/download/symbols;C:\Program Files (x86)\PHP\debug
Executable search path is:
ModLoad: 00000000`01280000 00000000`01292000 C:\Program Files (x86)\PHP\php.exe
ModLoad: 00000000`776e0000 00000000`77889000 C:\Windows\SYSTEM32\ntdll.dll
ModLoad: 00000000`778c0000 00000000`77a40000 ntdll.dll
ModLoad: 00000000`75010000 00000000`7504f000 C:\Windows\SYSTEM32\wow64.dll
ModLoad: 00000000`74fb0000 00000000`7500c000 C:\Windows\SYSTEM32\wow64win.dll
ModLoad: 00000000`74fa0000 00000000`74fa8000 C:\Windows\SYSTEM32\wow64cpu.dll
ModLoad: 00000000`773b0000 00000000`774c0000 KERNEL32.dll
ModLoad: 00000000`75420000 00000000`75467000 KERNELBASE.dll
ModLoad: 00000000`74580000 00000000`74b75000 php5ts.dll
ModLoad: 00000000`755e0000 00000000`75680000 ADVAPI32.dll
ModLoad: 00000000`75680000 00000000`7572c000 msvcrt.dll
ModLoad: 00000000`76100000 00000000`76119000 SECHOST.dll
ModLoad: 00000000`75a70000 00000000`75b60000 RPCRT4.dll
ModLoad: 00000000`75310000 00000000`75370000 SspiCli.dll
ModLoad: 00000000`75300000 00000000`7530c000 CRYPTBASE.dll
ModLoad: 00000000`75370000 00000000`753a5000 WS2_32.dll
ModLoad: 00000000`75470000 00000000`75476000 NSI.dll
ModLoad: 00000000`742b0000 00000000`7433c000 ODBC32.dll
ModLoad: 00000000`75970000 00000000`75a70000 USER32.dll
ModLoad: 00000000`75bc0000 00000000`75c50000 GDI32.dll
ModLoad: 00000000`75510000 00000000`7551a000 LPK.dll
ModLoad: 00000000`75f00000 00000000`75f9d000 USP10.dll
ModLoad: 00000000`75fa0000 00000000`760fc000 ole32.dll
ModLoad: 00000000`74340000 00000000`74384000 DNSAPI.dll
ModLoad: 00000000`73fe0000 00000000`74083000 MSVCR90.dll
ModLoad: 00000000`75730000 00000000`75790000 IMM32.dll
ModLoad: 00000000`75d80000 00000000`75e4c000 MSCTF.dll
ModLoad: 00000000`743c0000 00000000`743f8000 image00000000`743c0000
ModLoad: 00000000`74f70000 00000000`74f9b000 php_xdebug.dll
ModLoad: 00000000`10000000 00000000`10023000 php_apc.dll
ModLoad: 00000000`74e50000 00000000`74e62000 php_bz2.dll
ModLoad: 00000000`74dd0000 00000000`74e44000 php_curl.dll
ModLoad: 00000000`03160000 00000000`0325f000 LIBEAY32.dll
ModLoad: 00000000`74ba0000 00000000`74ba7000 WSOCK32.dll
ModLoad: 00000000`00210000 00000000`00247000 SSLEAY32.dll
ModLoad: 00000000`75b70000 00000000`75bb5000 WLDAP32.dll
ModLoad: 00000000`71d70000 00000000`71fb2000 php_fileinfo.dll
ModLoad: 00000000`58ca0000 00000000`58e3a000 php_gd2.dll
ModLoad: 00000000`74d00000 00000000`74d25000 php_intl.dll
ModLoad: 00000000`4a800000 00000000`4a940000 icuuc49.dll
ModLoad: 00000000`4ad00000 00000000`4be22000 icudt49.dll
ModLoad: 00000000`71a40000 00000000`71ace000 MSVCP90.dll
ModLoad: 00000000`03260000 00000000`033ff000 icuin49.dll
ModLoad: 00000000`74bd0000 00000000`74cfa000 php_mbstring.dll
ModLoad: 00000000`74db0000 00000000`74dbc000 php_mysql.dll
ModLoad: 00000000`74bb0000 00000000`74bc9000 php_mysqli.dll
ModLoad: 00000000`74550000 00000000`74577000 php_oci8_11g.dll
ModLoad: 00000000`03400000 00000000`034fb000 OCI.dll
ModLoad: 00000000`73eb0000 00000000`73f4b000 MSVCR80.dll
ModLoad: 00000000`76140000 00000000`76145000 PSAPI.DLL
ModLoad: 00000000`74530000 00000000`74545000 php_openssl.dll
ModLoad: 00000000`74da0000 00000000`74daa000 php_pdo_mysql.dll
ModLoad: 00000000`744c0000 00000000`7452a000 php_pdo_sqlite.dll
ModLoad: 00000000`71d30000 00000000`71d6f000 php_soap.dll
ModLoad: 00000000`744b0000 00000000`744bd000 php_sockets.dll
ModLoad: 00000000`741a0000 00000000`741bc000 IPHLPAPI.DLL
ModLoad: 00000000`74190000 00000000`74197000 WINNSI.DLL
ModLoad: 00000000`71c80000 00000000`71d2b000 php_sqlite3.dll
ModLoad: 00000000`74f30000 00000000`74f6c000 MSWSOCK.dll
ModLoad: 00000000`74dc0000 00000000`74dc6000 WSHIP6.dll
ModLoad: 00000000`74d30000 00000000`74d35000 WSHTCPIP.dll
ModLoad: 00000000`710c0000 00000000`71140000 UxTheme.dll
ModLoad: 00000000`71440000 00000000`71453000 dwmapi.dll
(1508.2510): Break instruction exception - code 80000003 (first chance)
ntdll!DbgBreakPoint:
00000000`77730530 cc int 3
0:003> g
(1508.12e0): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
*** ERROR: Symbol file could not be found. Defaulted to export symbols for php_xdebug.dll -
php_xdebug!xdebug_init_oparray+0x271e:
74f77a9e 80392a cmp byte ptr [ecx],2Ah ds:002b:00000000=??
*** ERROR: Symbol file could not be found. Defaulted to export symbols for php5ts.dll -


The backtrace looks like this:
WARNING: Stack unwind information not available. Following frames may be wrong.
php_xdebug!xdebug_init_oparray+0x271e
php_xdebug!xdebug_init_oparray+0x2c16
php5ts!zend_hash_exists+0x3f3
php_xdebug!xdebug_init_oparray+0x3340
php_xdebug!xdebug_init_oparray+0x84ff
php_xdebug!xdebug_init_oparray+0x8543
php_xdebug!xdebug_init_oparray+0xb13e


PHP Version:
PHP 5.4.14 (cli) (built: Apr 10 2013 21:20:02)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
    with Xdebug v2.2.3, Copyright (c) 2002-2013, by Derick Rethans
TagsNo tags attached.
Operating SystemWindows 7
PHP Version5.4.10-5.4.14

Activities

naitsirch

2013-06-24 11:47

reporter  

debugging exception.png (207,735 bytes)
debugging exception.png (207,735 bytes)

naitsirch

2013-06-24 13:07

reporter  

naitsirch

2013-06-24 13:08

reporter   ~0002517

Sorry, in the first uploaded screenshot I forgot to mark the interesting parts :-(

derick

2016-11-28 19:29

administrator   ~0003810

Is this still a problem for you?

naitsirch

2016-11-28 20:04

reporter   ~0003812

I don't know when it occured the last time, so maybe it's already fixed ;-)

derick

2016-11-28 21:10

administrator   ~0003822

Okay - thanks for letting me know. I'll close it then. Please reopen if you run into this (same) problem again.

Issue History

Date Modified Username Field Change
2013-06-24 11:47 naitsirch New Issue
2013-06-24 11:47 naitsirch File Added: debugging exception.png
2013-06-24 13:07 naitsirch File Added: debugging exception (edited).png
2013-06-24 13:08 naitsirch Note Added: 0002517
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-28 19:29 derick Note Added: 0003810
2016-11-28 19:29 derick Assigned To => derick
2016-11-28 19:29 derick Status new => feedback
2016-11-28 20:04 naitsirch Note Added: 0003812
2016-11-28 20:04 naitsirch Status feedback => assigned
2016-11-28 21:10 derick Note Added: 0003822
2016-11-28 21:10 derick Status assigned => resolved
2016-11-28 21:10 derick Resolution open => no change required