View Issue Details

IDProjectCategoryView StatusLast Update
0000957XdebugDocumentationpublic2016-11-28 19:49
Reportera.simonAssigned Toderick 
PriorityhighSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
PlatformOSWindows XPOS Version
Product Version 
Target VersionFixed in Version 
Summary0000957: Wizard doesn't mention DLL file name
DescriptionThe setup wizard doesn't include the xdebug dll file name in the line

zend_extension="..."

Thus, novice users have no idea why their XDebug installation doesn't work.

(see screenshot)

Root cause is probably this line:

Notice: Undefined property: xdebugVersion::$xdebugVersionToInstall in /var/www/servers/xdebug.org/html/wizard.php on line 42
TagsNo tags attached.
Operating System
PHP Version5.4-dev

Activities

a.simon

2013-07-04 10:29

reporter  

derick

2013-07-04 11:25

administrator   ~0002529

Could you supply me with the exact text you pasted in? Preferably as a zipped file.

Cheers
Derick

a.simon

2013-07-04 13:41

reporter  

phpinfo-3.zip (7,859 bytes)

a.simon

2013-07-04 13:46

reporter  

phpinfo-clean.zip (60,475 bytes)

a.simon

2013-07-04 13:51

reporter   ~0002530

Last edited: 2013-07-04 13:51

View 2 revisions

Hi Derick,

phpinfo-3.zip contains the output of "php -i" after I've figured out i'll have to add this into my php.ini:

> zend_extension = "E:/Programme/PHP/php_xdebug-2.2.3-5.4-vc9.dll"

The screenshot above is what I get when uploading this phpinfo output.

I've included the original phpinfo() output, before adding that line, too. See the file phpinfo-clean.zip for the "php -i" output (it's lacking the XDebug lines) and the screenshot included in that zip shows how the PHP warning isn't shown, but still, the DLL file path isn't printed by the wizard, which then looks like you have to just set the directory where the DLL is located (which isn't enough to get it to work)

Thank you for your support,

Artjom

derick

2016-11-28 19:49

administrator   ~0003811

I can't reproduce this. If the wizard still gives wrong results for you, please create a new ticket with the phpinfo() output (zipped, in a text file), and a screenshot again.

Issue History

Date Modified Username Field Change
2013-07-04 10:29 a.simon New Issue
2013-07-04 10:29 a.simon File Added: xdebug-wizard-empty-filename.png
2013-07-04 11:25 derick Note Added: 0002529
2013-07-04 11:25 derick Assigned To => derick
2013-07-04 11:25 derick Status new => feedback
2013-07-04 13:41 a.simon File Added: phpinfo-3.zip
2013-07-04 13:46 a.simon File Added: phpinfo-clean.zip
2013-07-04 13:51 a.simon Note Added: 0002530
2013-07-04 13:51 a.simon Status feedback => assigned
2013-07-04 13:51 a.simon Note Edited: 0002530 View Revisions
2016-11-28 19:49 derick Note Added: 0003811
2016-11-28 19:49 derick Status assigned => resolved
2016-11-28 19:49 derick Resolution open => no change required