View Issue Details

IDProjectCategoryView StatusLast Update
0000959XdebugUsage problems (Wrong Results)public2014-02-27 19:53
ReporterquerdenkerAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformWindowsOSWindows 7 64bitOS VersionVersion 6.1.7601
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000959: Remote debugging: Client (xdebug) always tries to connect to server (IDE)
DescriptionRunning xampp 1.8.1 (Apache 2.4.3, PHP 5.4.7) on Win7 SP1 64bit. The remote debugging server is Jetbrains PhpStorm 6.0.3. The xdebug DDL I use is php_xdebug-2.2.3-5.4-vc9.dll. According to phpinfo(), the xdebug settings are

xdebug.auto_trace Off
xdebug.cli_color 1
xdebug.collect_assignments Off
xdebug.collect_includes On
xdebug.collect_params 0
xdebug.collect_return Off
xdebug.collect_vars Off
xdebug.coverage_enable On
xdebug.default_enable On
xdebug.dump.COOKIE no value
xdebug.dump.ENV no value
xdebug.dump.FILES no value
xdebug.dump.GET no value
xdebug.dump.POST no value
xdebug.dump.REQUEST no value
xdebug.dump.SERVER no value
xdebug.dump.SESSION no value
xdebug.dump_globals On
xdebug.dump_once On
xdebug.dump_undefined Off
xdebug.extended_info On
xdebug.file_link_format no value
xdebug.idekey xdebug
xdebug.max_nesting_level 100
xdebug.overload_var_dump On
xdebug.profiler_aggregate Off
xdebug.profiler_append Off
xdebug.profiler_enable Off
xdebug.profiler_enable_trigger Off
xdebug.profiler_output_dir C:\Users\dk\Development\xampp\tmp
xdebug.profiler_output_name xdebug_profile.%R::%u
xdebug.remote_autostart Off
xdebug.remote_connect_back Off
xdebug.remote_cookie_expire_time 3600
xdebug.remote_enable On
xdebug.remote_handler dbgp
xdebug.remote_host localhost
xdebug.remote_log no value
xdebug.remote_mode req
xdebug.remote_port 9000
xdebug.scream Off
xdebug.show_exception_trace Off
xdebug.show_local_vars Off
xdebug.show_mem_delta Off
xdebug.trace_enable_trigger Off
xdebug.trace_format 0
xdebug.trace_options 0
xdebug.trace_output_dir C:\Users\dk\Development\xampp\tmp
xdebug.trace_output_name trace.%c
xdebug.var_display_max_children -1
xdebug.var_display_max_data -1
xdebug.var_display_max_depth -1

Even though xdebug.remote_autostart is set to Off and I do not send XDEBUG_SESSION=xdebug or XDEBUG_SESSION_START=xdebug along (neither GET/POST/COOKIE), xdebug always responds Set-Cookie XDEBUG_SESSION=xdebug;[...] and tries to connect to a server (if a listening PhpStorm runs, it'll connect to that).

If xdebug is designed to work this way (always starting a remote debugging session), then what is the purpose of the xdebug.remote_autostart setting? Furthermore, what's the purpose of all the GET/POST/COOKIE remote debug session start stuff, including browser extensions like easyXdebug (Firefox)?
Steps To Reproduce- Set up php_xdebug as described above (especially xdebug.remote_autostart=Off)
- Call a simple PHP script (without any GET/POST/COOKIE parameters)
- Check response headers (Set-Cookie)
TagsNo tags attached.
Operating System
PHP Version5.4.7

Activities

derick

2013-07-09 07:56

administrator   ~0002532

Can you check if the *request* headers contain a the cookie? If that's the case, your browser sends it. This could be because of a browser plugin that is activated.

querdenker

2013-07-09 15:04

reporter   ~0002534

Last edited: 2013-07-09 15:05

View 2 revisions

Alright, I guess you can just close this report. In order to resolve this, I screwed around with some xdebug settings in the php.ini file. When I changed the value of xdebug.idekey to "foobar", my browser kept receiving the cookie XDEBUG_SESSION=xdebug. So there had to be something that sets the idekey/session name outside of the php.ini. In the end, I found a system environment variable which I must have set a while ago to debug a PHP-CLI script or something. That variable was XDEBUG_CONFIG with the value idekey=xdebug remote_host=localhost. Once I removed that system variable and restarted Windows, xdebug remote debugging didn't start automatically any longer.

derick

2014-02-27 19:53

administrator   ~0002718

I am glad to know that it works now! Closing this issue.

Issue History

Date Modified Username Field Change
2013-07-05 09:31 querdenker New Issue
2013-07-09 07:56 derick Note Added: 0002532
2013-07-09 07:56 derick Assigned To => derick
2013-07-09 07:56 derick Status new => feedback
2013-07-09 15:04 querdenker Note Added: 0002534
2013-07-09 15:04 querdenker Status feedback => assigned
2013-07-09 15:05 querdenker Note Edited: 0002534 View Revisions
2014-02-27 19:53 derick Note Added: 0002718
2014-02-27 19:53 derick Status assigned => resolved
2014-02-27 19:53 derick Resolution open => no change required
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)