View Issue Details

IDProjectCategoryView StatusLast Update
0000979XdebugFeature/Change requestpublic2013-09-28 13:33
ReporterericpAssigned Toderick 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version2.2.0 
Target VersionFixed in Version2.2.4 
Summary0000979: It would be good if property_value recognized that -m 0 requests all bytes, not zero bytes
DescriptionI'm posting this because I don't see a way of commenting on
http://bugs.xdebug.org/view.php?id=846

I looked for an empty text box, a button or label saying "Reply", and
maybe because the bug is closed, I can't reply. But this is problematic.

In Komodo, all the other languages implement '-m 0' as a request for all bytes.
The assumption is that if you really wanted 0 bytes, why would you make this request? So '0' must mean something else....

I see that the breakage from older behaviour is due to the removal of the 'options->max_data == 0' test in xdebug_var_export_xml_node, so xdebug used to make the same assumption every other language engine I'm familiar with does.
Please reinstate it.
TagsNo tags attached.
Operating System
PHP Version5.4.5

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2013-09-24 23:38 ericp New Issue
2013-09-28 13:33 derick Status new => closed
2013-09-28 13:33 derick Assigned To => derick
2013-09-28 13:33 derick Resolution open => fixed
2013-09-28 13:33 derick Fixed in Version => 2.2.4