MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000982XdebugFeature/Change requestpublic2013-10-02 09:542015-02-22 14:30
Reporteraik099 
Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformSlackwareOSLinuxOS Version13.3
Product Version2.2.3 
Target VersionFixed in Version2.3.0 
Summary0000982: Incorrect file paths in exception stack trace
DescriptionWhen Xdebug is printing out a stack trace (in orange) for an exception it thinks, that all files are in parent folder (..) for no reason (see image). In fact I have files scattered all over place (but within DocumentRoot of course).
Additional InformationPHP Version: 5.4.20
TagsNo tags attached.
Operating System
PHP Version5.4.10-5.4.14
Attached Filespng file icon xdebug_wrong_stracktrace_paths.png [^] (108,865 bytes) 2013-10-02 09:54

- Relationships

-  Notes
(0002571)
aik099 (reporter)
2013-10-02 10:01

File, that throws exception: /modules/custom/units/sections/site_domains/e_site_domain_eh.php
File, that is visited in browser to start the process: /admin/index.php
DocumentRoot: /mnt/hd/home/alex/web

File paths from stack trace (if inspecting in debugger in PhpStorm):

* /mnt/hd/home/alex/web/p/catalyst-demo/core/kernel/event_handler.php
* /mnt/hd/home/alex/web/p/catalyst-demo/core/kernel/event_manager.php
* /mnt/hd/home/alex/web/p/catalyst-demo/core/kernel/application.php

It seems, that xdebug tries to figure out common path to replace with "..", but does that too aggressively. Removing DocumentRoot from all paths might be a good idea anyway.
(0002636)
derick (administrator)
2013-12-04 00:10

This is not a bug. Xdebug doesn't really mean "parent directory" with "../". It just means there is something before the /. If you hover over the filename, then you get the full path.
(0002638)
aik099 (reporter)
2013-12-04 08:17

Then you should use 3 dots (e.g. ".../filename.php") to indicate that the path is shortened and there is more to see. 3 dots at the end of text (e.g. "some text ...") exactly does that.

In file path the "../" always means parent folder and this is what most of people would think about it, when they see it.

Fact, that I can hover over to see full path isn't obvious either. I surely won't be trying to hover over each cell in stack trace table in hopes to get extra info. Usually if hovering over will show something, then element should be underlined with a dashed line. If clicking on element, then it should be underlined from the beginning or while hovering over on it (usual behavior with links).

Xdebug is great debugging product, but common-sense GUI principles still need to be applied.

P.S.
Could you please be more responsive. I've posted this issue 2 month ago and only now I'm getting the answer that there is nothing to be fixed.
(0002747)
derick (administrator)
2014-03-05 09:20

As this is a minor issue, it's not very high on my list of things to look at. I'll see what I can do.
(0002798)
aik099 (reporter)
2014-04-26 08:14

It's that hard to add one dot in path name (will be "..." instead of "..") to make things clearer?
(0002799)
derick (administrator)
2014-04-26 10:08
edited on: 2015-02-22 11:42

I closed it as fixed last night already..., because I've fixed it: https://github.com/xdebug/xdebug/commit/1e13ca94dd66bbb462fc1dcd4402849377f1592b [^]


- Issue History
Date Modified Username Field Change
2013-10-02 09:54 aik099 New Issue
2013-10-02 09:54 aik099 File Added: xdebug_wrong_stracktrace_paths.png
2013-10-02 10:01 aik099 Note Added: 0002571
2013-12-04 00:10 derick Note Added: 0002636
2013-12-04 00:10 derick Status new => resolved
2013-12-04 00:10 derick Resolution open => no change required
2013-12-04 00:10 derick Assigned To => derick
2013-12-04 08:17 aik099 Note Added: 0002638
2013-12-04 08:17 aik099 Status resolved => feedback
2013-12-04 08:17 aik099 Resolution no change required => reopened
2014-03-05 09:20 derick Note Added: 0002747
2014-03-05 09:20 derick Status feedback => assigned
2014-04-26 00:01 derick Status assigned => closed
2014-04-26 00:01 derick Resolution reopened => fixed
2014-04-26 00:01 derick Fixed in Version => 2.3dev
2014-04-26 08:14 aik099 Note Added: 0002798
2014-04-26 08:14 aik099 Status closed => feedback
2014-04-26 08:14 aik099 Resolution fixed => reopened
2014-04-26 10:08 derick Note Added: 0002799
2014-04-26 10:08 derick Status feedback => closed
2014-04-26 10:08 derick Resolution reopened => fixed
2015-02-22 11:42 derick Note Edited: 0002799 View Revisions
2015-02-22 11:42 derick Category Usage problems => Feature/Change request
2015-02-22 14:30 derick Fixed in Version 2.3dev => 2.3.0


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker