View Issue Details

IDProjectCategoryView StatusLast Update
0001488XdebugRemote Debuggingpublic2019-05-06 15:46
ReporterderickAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version2.7.0devFixed in Version2.7.2 
Summary0001488: Rewrite property_set to use eval
DescriptionThis is needed after The Great Variable Reading Refactor of 2017.
TagsNo tags attached.
Operating System
PHP Version7.1.0-7.1.4

Relationships

has duplicate 0001499 resolvedderick property_set: unable to change array item value 
has duplicate 0001638 resolvedderick Can't change string variable contents, property_set with string type has no effect 

Activities

travis

2019-02-27 18:09

reporter   ~0004929

Will there be a RC3 to get this into v2.7.0?

derick

2019-02-28 14:07

administrator   ~0004930

I think it is unlikely that it will make it into 2.7.0, as I really need to get that out ASAP. You'll likely find this fixed in 2.7.1.

travis

2019-02-28 16:08

reporter   ~0004931

Thanks mate!

derick

2019-04-12 14:41

administrator   ~0004990

Looks like there is little to do here. `property_set` already uses eval, unless the `-t` option is used. PhpStorm, and I bet other IDEs, don't actually use the `-t` option. Is there anything going wrong for you here travis?

zb3_got_no_mail

2019-04-12 14:47

reporter   ~0004991

Elipse uses the `-t` option to change string variables

zb3_got_no_mail

2019-04-12 14:48

reporter   ~0004992

Whoops, I meant Eclipse.

See here:
https://github.com/eclipse/pdt/blob/60c4dff8790a78f1f540141e220d12e2ce9e1ead/plugins/org.eclipse.php.debug.core/src/org/eclipse/php/internal/debug/core/xdebug/dbgp/model/DBGpTarget.java#L1512

travis

2019-04-12 15:05

reporter   ~0004993

I do know that Komodo IDE uses the -t option because that's how I found this issue. I _think_ Sublime uses it too, although I wasn't looking at the logs when it seemed to exhibit the same behavior.

Is this deprecated usage? Is there a replacement option Komodo should be using for the same functionality?

derick

2019-04-12 15:08

administrator   ~0004994

Cheers! Apparently it does that specifically to not use "eval" ... but, it's going to have to now.

derick

2019-04-12 15:10

administrator   ~0004995

@travis, Komodo uses this just fine. I will have to update the code to do something clever when the -t is passed with the eval (likely, put the right "(int)" cast in front of it).

travis

2019-04-12 15:45

reporter   ~0004996

Thanks mate!

Cheers for all the work you do on this. It's been a life-saver.

derick

2019-04-12 15:48

administrator   ~0004997

PR with initial code is at https://github.com/xdebug/xdebug/pull/465, but I need to add tests still.

Issue History

Date Modified Username Field Change
2017-11-06 11:35 derick New Issue
2017-12-05 14:00 derick Relationship added has duplicate 0001499
2017-12-16 17:34 derick Assigned To => derick
2017-12-16 17:34 derick Status new => assigned
2018-09-20 07:42 derick Target Version 2.6.0dev => 2.7.0dev
2019-01-22 21:25 derick Target Version 2.7.0dev =>
2019-01-22 22:28 derick Status assigned => confirmed
2019-02-21 21:42 derick Target Version => 2.7.0
2019-02-21 21:44 derick Relationship added has duplicate 0001638
2019-02-27 18:09 travis Note Added: 0004929
2019-02-28 14:07 derick Note Added: 0004930
2019-02-28 16:08 travis Note Added: 0004931
2019-02-28 17:54 derick Target Version 2.7.0 => 2.7.0dev
2019-04-12 14:41 derick Note Added: 0004990
2019-04-12 14:47 zb3_got_no_mail Note Added: 0004991
2019-04-12 14:48 zb3_got_no_mail Note Added: 0004992
2019-04-12 15:05 travis Note Added: 0004993
2019-04-12 15:08 derick Note Added: 0004994
2019-04-12 15:10 derick Note Added: 0004995
2019-04-12 15:45 travis Note Added: 0004996
2019-04-12 15:48 derick Note Added: 0004997
2019-04-14 17:12 derick Status confirmed => closed
2019-04-14 17:12 derick Resolution open => fixed
2019-04-14 17:12 derick Fixed in Version => 2.7.2
2019-04-14 17:12 derick Fixed in Version 2.7.2 => 2.7.0dev
2019-05-06 15:46 derick Fixed in Version 2.7.0dev => 2.7.2