View Issue Details

IDProjectCategoryView StatusLast Update
0000307Xdebug(No Category)public2007-09-05 16:11
ReporternsowenAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000307: Segmentation fault when loading xdebug.so on Solaris 9
DescriptionAfter compiling without any problems, xdebug.so cannot be loaded successfully. PHP crashes with SIGSEGV. Other modules work just fine.
Additional InformationCompiled with:
gcc 3.4.2 on SunOS compile 5.9 Generic_117171-13 sun4u
sparc SUNW,UltraAX-i2.

Backtrace:
root@compile:/root/nsowen# gdb --args php/bin/php -c php.xdebug.ini -i
GNU gdb 6.6
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "sparc-sun-solaris2.9"...
(gdb) run
Starting program: /root/nsowen/php/bin/php -c php.xdebug.ini -i
warning: Temporarily disabling breakpoints for unloaded shared library "/usr/lib/ld.so.1"

Program received signal SIGSEGV, Segmentation fault.
0x002b1e14 in OnUpdateLong ()
(gdb) bt
#0 0x002b1e14 in OnUpdateLong ()
#1 0x002b1698 in zend_register_ini_entries ()
0000002 0xfe98a974 in zm_startup_xdebug (type=1, module_number=30) at /root/nsowen/xdebug-2.0.0/xdebug.c:541
0000003 0x002a4f80 in zend_startup_module_ex ()
0000004 0x002a5f74 in zend_startup_module ()
0000005 0xfe9942c0 in xdebug_zend_startup (extension=0x5d0ea0) at /root/nsowen/xdebug-2.0.0/xdebug.c:3071
0000006 0x002a7ef0 in zend_extension_startup ()
0000007 0x00295834 in zend_llist_apply_with_del ()
0000008 0x002a7f90 in zend_startup_extensions ()
0000009 0x0025d220 in php_module_startup ()
0000010 0x0031e7b8 in main ()
TagsNo tags attached.
Operating SystemSunOS 5.9 Generic_117171-13
PHP Version5.1.6

Relationships

duplicate of 0000301 closed Loading would cause SIGBUS on Solaris 10 SPARC 

Activities

derick

2007-09-05 16:11

administrator   ~0000721

Already fixed in CVS: http://article.gmane.org/gmane.comp.php.xdebug.devel/1135

Issue History

Date Modified Username Field Change
2007-09-05 16:05 nsowen New Issue
2007-09-05 16:11 derick Status new => resolved
2007-09-05 16:11 derick Resolution open => duplicate
2007-09-05 16:11 derick Relationship added duplicate of 0000301
2007-09-05 16:11 derick Assigned To => derick
2007-09-05 16:11 derick Note Added: 0000721
2016-07-31 13:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 13:35 derick Category debugclient (debugging tool) => (No Category)