View Issue Details

IDProjectCategoryView StatusLast Update
0001026XdebugInstallationpublic2016-12-23 21:26
ReporterCoffee_fanAssigned Toderick 
Status resolvedResolutionno change required 
PlatformWindows 8.1 64bitsOSWindowsOS Version6.3.9600
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001026: XDebug loads from command line, but does not show via web ui
DescriptionI installed several versions of php from I normally run these with Wincache w/o problems. This time around however I disabled the wincache extension to simplify things and enable xdebug in a known environment:

1) I went through the xdebug wizard and downloaded corresponding library for my interpreter (php-5.2.17-nts-Win32-VC6-x86). xdebug is: php_xdebug-2.2.3-5.2-vc9-nts.dll.

Using php 5.2.17 I get the erroneous behavior described.
Steps To Reproducerun from CLI
php -v

Result: Module shows as loaded.

browse to a local <?php phpinfo(); ?> script on the local server:

Result: Module does not show as loaded.
Additional InformationNotes:

- My 5.2 version is 5.2.17
- I also tried the combo php-5.3.27-nts-Win32-VC9-x86 + php_xdebug-2.2.3-5.3-vc9-nts.dll. Results are the same, xdebug loads from CLI but not from IIS.
- I also tried to use php_xdebug-2.2.1-5.2-vc9-nts.dll. This one loads on IIS, but as soon as I try to go to php code it throws an IIS error page. I can send this if needed.
- I also tried enabling 32bit mode apps on the AppPools to no avail.

If you need more information, I will be glad to send.
TagsNo tags attached.
Operating SystemWindows
PHP Version5.2.10



2014-01-13 10:59

administrator   ~0002668

Have you tried the wizard at to figure out the correct file and where to make configuration settings?


2014-01-13 23:33

reporter   ~0002669

Yup, in point 1) in description. So, basically for all the versions I tried, except the 2.2.1, I used the wizard to determine the proper version and I did the fixes suggested at the end of the wizard.


2016-11-28 21:26

administrator   ~0003825

Is this still a problem for you?


2016-12-23 21:26

administrator   ~0004099

Closing this, as the requested feedback whether it's still a problem wasn't answered. Please reopen this issue if necessary.

Issue History

Date Modified Username Field Change
2014-01-13 01:29 Coffee_fan New Issue
2014-01-13 10:59 derick Note Added: 0002668
2014-01-13 10:59 derick Assigned To => derick
2014-01-13 10:59 derick Status new => feedback
2014-01-13 23:33 Coffee_fan Note Added: 0002669
2014-01-13 23:33 Coffee_fan Status feedback => assigned
2016-11-28 21:26 derick Note Added: 0003825
2016-11-28 21:26 derick Status assigned => feedback
2016-12-23 21:26 derick Note Added: 0004099
2016-12-23 21:26 derick Status feedback => resolved
2016-12-23 21:26 derick Resolution open => no change required