View Issue Details

IDProjectCategoryView StatusLast Update
0001031XdebugUsage problems (Wrong Results)public2016-12-04 17:23
ReporteralexhAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformOSMac OSXOS Version10.9.1
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001031: Closing braces ignored by code coverage
DescriptionDuring code coverage reports through PHPUnit, a closing brace is being considered as "not-covered".
Steps To ReproduceCode attached to ticket and available here:
https://gist.github.com/alexhouse/8977684
Additional InformationPHPUnit 3.7.31
XDebug 2.2.3
PHP 5.4.25
TagsNo tags attached.
Operating SystemMac OSX
PHP Version5.4.20-5.4.24

Activities

alexh

2014-02-13 15:58

reporter  

BraceTest.zip (682 bytes)

alexh

2014-02-13 16:03

reporter  

CoverageTest.png (100,720 bytes)
CoverageTest.png (100,720 bytes)

derick

2014-03-05 09:30

administrator   ~0002750

I'll have a look.

derick

2016-12-04 17:23

administrator   ~0003923

The result is correct here. None of your test cases cover the case where if ($get_something) (on line 9) is false. Because there is a fall back at the end, there is code on line 16. You never get there though, although you *can* get there logically, if $get_something in line 9 is false.

Issue History

Date Modified Username Field Change
2014-02-13 15:58 alexh New Issue
2014-02-13 15:58 alexh File Added: BraceTest.zip
2014-02-13 16:03 alexh File Added: CoverageTest.png
2014-03-05 09:30 derick Note Added: 0002750
2014-03-05 09:30 derick Assigned To => derick
2014-03-05 09:30 derick Status new => assigned
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-28 21:28 derick Status assigned => acknowledged
2016-12-04 17:23 derick Note Added: 0003923
2016-12-04 17:23 derick Status acknowledged => resolved
2016-12-04 17:23 derick Resolution open => no change required