View Issue Details

IDProjectCategoryView StatusLast Update
0001033XdebugFeature/Change requestpublic2016-12-11 13:05
Reporteraik099Assigned Toderick 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionduplicate 
PlatformLinuxOSSlackwareOS Version13.37
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001033: Show PHP errors during debugging as they happen (by supporting stderr)
DescriptionI have following code:

$line1 = '';
$line2 = in_array(5, $line1);
$line3 = '';

I start debugging with breakpoint on line1. Then step into line2 (all good). Then after line2 code is executed I get an error since string is put instead of array in "in_array" function. I want to see that error as it happens (including notices/warning/exceptions/fatal errors).

Right now I see all errors only after debugging is finished.

Maybe related to http://youtrack.jetbrains.com/issue/WI-9653
TagsNo tags attached.
Operating System
PHP Version5.4.15-5.4.20

Relationships

duplicate of 0000665 closedderick xdebug does not respect display_errors=stderr 

Activities

derick

2014-03-05 09:29

administrator   ~0002749

I've changed this to a feature request, but I can not really see how I can implement this as unlike stdout (PHP output), I don't think I can hook into the stderr stream that PHP creates. I will have to see whether this is now possible with the new output handling mechanism in PHP 5.5 though.

aik099

2014-03-05 09:36

reporter   ~0002756

I can tell, that Zend Debugger does that somehow (even on PHP 4). And PhpStorm uses that to display errors as they happen in Console.

derick

2016-12-11 13:05

administrator   ~0003985

Should have been solved through 0000665.

Issue History

Date Modified Username Field Change
2014-02-23 08:02 aik099 New Issue
2014-03-05 09:28 derick Category Debug client (console) => Feature/Change request
2014-03-05 09:28 derick Summary Show PHP errors during debugging as they happen => Show PHP errors during debugging as they happen (by supporting stderr)
2014-03-05 09:29 derick Note Added: 0002749
2014-03-05 09:36 aik099 Note Added: 0002756
2016-12-11 13:05 derick Note Added: 0003985
2016-12-11 13:05 derick Relationship added duplicate of 0000665
2016-12-11 13:05 derick Status new => resolved
2016-12-11 13:05 derick Resolution open => duplicate
2016-12-11 13:05 derick Assigned To => derick