View Issue Details

IDProjectCategoryView StatusLast Update
0001043XdebugUsage problems (Wrong Results)public2014-05-19 23:37
ReporterremiAssigned Toderick 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionunable to reproduce 
PlatformGNU/LinuxOSFedoraOS Version20
Product Version2.2.4 
Target VersionFixed in Version 
Summary0001043: Possible null deref
DescriptionIn fetch_zval_from_symbol_table

Bug report https://bugzilla.redhat.com/show_bug.cgi?id=1081000
Backtrace https://bugzilla.redhat.com/attachment.cgi?id=878990
Steps To Reproduce?
Additional InformationA trivial fix could be:

if (ht && zend_hash_find(ht, element, element_length + 1, (void **) &retval_pp) == SUCCESS) {
    if (retval_pp) {
      retval_p = *retval_pp;
    }
    goto cleanup;
  }

But I don't enough about XDebug internals and if this is revelant.
Else, corrupted value in retval_pp could show some memory corruption.
TagsNo tags attached.
Operating System
PHP Version5.5.5-5.5.9

Activities

derick

2014-05-19 23:37

administrator   ~0002829

Sorry, but I can't see how that situation can be reached. I can't reproduce it and your linked reports have no reproducible script either. I'm afraid I'll have to close it unless there is more information.

Issue History

Date Modified Username Field Change
2014-03-26 13:49 remi New Issue
2014-05-19 23:37 derick Note Added: 0002829
2014-05-19 23:37 derick Status new => resolved
2014-05-19 23:37 derick Resolution open => unable to reproduce
2014-05-19 23:37 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)