View Issue Details

IDProjectCategoryView StatusLast Update
0001044XdebugUsage problems (Wrong Results)public2016-11-28 23:36
ReportervladimmiAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
Platformx64OSArch LinuxOS Versionkernel 3.13.7
Product Version2.2.4 
Target VersionFixed in Version 
Summary0001044: SEGFAULT when used with Phalcon
DescriptionI'm using Xdebug in project based on Phalcon (PHP framework built as extension - http://phalconphp.com). From recent versions of Phalcon it becomes crash at some place, httpd logs shows SEGFAULT of child process and backtraces from coredumps mention Xdebug.

Disabling Xdebug make code to work stable.

I've posted bug report in Phalcon tracker (https://github.com/phalcon/cphalcon/issues/2239), had recommendations to place it here too.
Steps To ReproduceIt's hard to figure out the reason from a big project, but step-by-step debug crashes in this code:

//$di = new Phalcon\DI\FactoryDefault();
$viewEngines = array(
    ".volt" => function($view, $di) {
        $volt = new \Phalcon\Mvc\View\Engine\Volt($view, $di);
        $volt->setOptions(array(
            'compiledPath' => PATH_APP_CACHE . 'views/',
            'compiledSeparator' => '_',
            'stat' => false,
            'compileAlways' => true
        ));

        //register functions...
        //register filters...

        return $volt;
    }
);

//Volt
$di->set('view', function() use($viewEngines) {
    $view = new \Phalcon\Mvc\View();
    $view->setViewsDir(PATH_APP_VIEWS);
    $view->registerEngines($viewEngines);
    return $view;
});

SEGFAULT happen just after "return $volt;" - which create object for DI container and returns it back.
Additional InformationArch Linux x64 with 3.13.7 kernel
Apache 2.4.9
PHP 5.5.10 NTS
Zend Engine 2.5.0
Zend OPcache 7.0.3
Xdebug 2.2.4
Phalcon 1.3.1 compiled from master

Tried to collect some information from coredump, bt full - https://gist.github.com/vladimmi/9787642
TagsNo tags attached.
Operating SystemArch Linux
PHP Version5.1.0

Activities

derick

2016-11-28 21:29

administrator   ~0003829

Does this still cause issues for you?

vladimmi

2016-11-28 21:58

reporter   ~0003835

Cant say anything now because after 2.5 years my setup and used technologies changed a lot.

derick

2016-11-28 23:36

administrator   ~0003840

Yeah, sorry for that :-) I'll close it then. Let me know if you run into problems again with Xdebug in a new issue.

Issue History

Date Modified Username Field Change
2014-03-27 14:21 vladimmi New Issue
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-28 21:29 derick PHP Version 5.5-dev => 5.1.0
2016-11-28 21:29 derick Note Added: 0003829
2016-11-28 21:29 derick Assigned To => derick
2016-11-28 21:29 derick Status new => feedback
2016-11-28 21:58 vladimmi Note Added: 0003835
2016-11-28 21:58 vladimmi Status feedback => assigned
2016-11-28 23:36 derick Note Added: 0003840
2016-11-28 23:36 derick Status assigned => resolved
2016-11-28 23:36 derick Resolution open => no change required