View Issue Details

IDProjectCategoryView StatusLast Update
0001050XdebugUsage problems (Wrong Results)public2014-06-14 10:32
Reporterbishwanath.jhaAssigned Toderick 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformApacheOSOSXOS Version10.8.3
Product Version 
Target VersionFixed in Version 
Summary0001050: Gives Error as Too many open files in Unknown on line 0 and Fatal error: Unknown: Failed opening required
DescriptionHi,

Found very wearied issue with xdebug on 2 php version i have tried upon (5.4.16 and 5.5.12).

When you try to access content from web browser you end up with below error,

========================================
Warning: Unknown: failed to open stream: Too many open files in Unknown on line 0

Fatal error: Unknown: Failed opening required '/Library/WebServer/Documents/project/trunk/admin/index.php' (include_path='.:/usr/lib/php') in Unknown on line 0
========================================

and further on hard refresh it clears and it appears very frequently on few page refresh.

Initially i thought its related to file permission or file_opening_limit(ulimit) but already having valid permissions set.

As soon as i compile xdebug and enable it in php.ini, restarts apache and hit url from web its gives error.

Just for check, i removed xdebug statement from php.ini everything started working fine.
Steps To ReproduceDownload xdebug, compile(configure, make), enable extension in php.ini and you start seeing above warning and fatal error.

This is the code i am using.

<?php
//Declarations
define('INTERFACE', 'client');
define('INTERFACEFILE', __FILE__);

if (defined("CUSTOMPATH"))
{
    chdir(CUSTOMPATH);
} else {
    chdir('./__project/');
}

require_once ('./project.php');

?>
Additional InformationFaced issue on php versions(5.4.16 and 5.5.12).
on 5.4.16 downloaded from https://github.com/derickr/xdebug
on 5.5.12 downloaded from http://xdebug.org/files/xdebug-2.2.5.tgz

as soon as i enable it in php.ini and restart apache and hit url from web its gives error.

Find below details from phpinfo might help you in debugging.

System:
Darwin Bishwanath-iMac.local 12.3.0 Darwin Kernel Version 12.3.0: Sun Jan 6 22:37:10 PST 2013; root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64

Configure Command :
'./configure' '--prefix=/usr' '--enable-cli' '--with-mcrypt' '--with-zlib' '--enable-mbstring' '--without-openssl' '--with-mysql' '--with-mysql-sock' '--with-curl' '--with-kerberos' '--with-pdo-mysql' '--with-gd' '--enable-gd-native-ttf' '--with-imap=/usr/src/imap-2007f' '--with-imap-ssl' '--with-apxs2=/usr/sbin/apxs' '--enable-embedded-mysqli' '--with-pdo-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--enable-so' '--enable-tidy=../tidy/' '--with-tidy' '--enable-opcache' '--enable-fpm'

Tailored suggested info : http://i.imgur.com/RZcU1Yv.png

php.ini snipped added for xdebug.
[xdebug]
zend_extension_ts=php_xdebug.dll
#zend_extension=/usr/lib/php/extensions/no-debug-non-zts-20121212/xdebug.so

xdebug.remote_enable = On
xdebug.remote_autostart = 1
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000
xdebug.remote_handler=dbgp
xdebug.profiler_enable=0
xdebug.profiler_output_name=cachegrind.out.%t-%s
xdebug.profiler_output_dir="/var/log/grind"
TagsNo tags attached.
Operating System MAC OSX 10.8.3
PHP Version5.4.10-5.4.14

Activities

derick

2014-05-16 09:33

administrator   ~0002810

Your php.ini snippet makes not much sense. You're loading a .dll file and you're on MacOSX?!

derick

2014-06-14 10:32

administrator   ~0002846

Unable to reproduce, and no feedback provided. I'm closing this out, but feel free to reopen if you can provide the requested information.

Issue History

Date Modified Username Field Change
2014-05-09 12:24 bishwanath.jha New Issue
2014-05-16 09:33 derick Note Added: 0002810
2014-05-16 09:33 derick Assigned To => derick
2014-05-16 09:33 derick Status new => feedback
2014-06-14 10:32 derick Note Added: 0002846
2014-06-14 10:32 derick Status feedback => resolved
2014-06-14 10:32 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)