View Issue Details

IDProjectCategoryView StatusLast Update
0001051XdebugUsage problems (Wrong Results)public2014-06-14 10:34
ReporterpaulgaoAssigned Toderick 
PriorityhighSeveritycrashReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSCentosOS Version6.5 X64
Product Version2.2.5 
Target VersionFixed in Version 
Summary0001051: coredump~
Description(gdb) bt
#0 0x000000000075c621 in zend_hash_quick_find (ht=0x2a11340, arKey=0x29e15c0 "118.26.235.98", nKeyLength=14, h=1622402878987271388, pData=0x7fff032521e8) at /root/php-5.5.11/Zend/zend_hash.c:950
#1 0x00000000007c8f6c in zend_isset_isempty_dim_prop_obj_handler_SPEC_VAR_CV (prop_dim=0, execute_data=0x7f82b371e658) at /root/php-5.5.11/Zend/zend_vm_execute.h:23918
0000002 0x00000000007c2f60 in execute_ex (execute_data=0x7f82b371e658) at /root/php-5.5.11/Zend/zend_vm_execute.h:363
0000003 0x00007f82a773f0bb in xdebug_execute_ex (execute_data=0x7f82b371e658) at /home/codebase/software/xdebug/xdebug.c:1465
0000004 0x00000000007d1b69 in zend_do_fcall_common_helper_SPEC (execute_data=0x7f82b371e3f0) at /root/php-5.5.11/Zend/zend_vm_execute.h:584
0000005 0x00000000007c2f60 in execute_ex (execute_data=0x7f82b371e3f0) at /root/php-5.5.11/Zend/zend_vm_execute.h:363
0000006 0x00007f82a773f0bb in xdebug_execute_ex (execute_data=0x7f82b371e3f0) at /home/codebase/software/xdebug/xdebug.c:1465
0000007 0x00000000007d1b69 in zend_do_fcall_common_helper_SPEC (execute_data=0x7f82b371e2e8) at /root/php-5.5.11/Zend/zend_vm_execute.h:584
0000008 0x00000000007c2f60 in execute_ex (execute_data=0x7f82b371e2e8) at /root/php-5.5.11/Zend/zend_vm_execute.h:363
0000009 0x00007f82a773f0bb in xdebug_execute_ex (execute_data=0x7f82b371e2e8) at /home/codebase/software/xdebug/xdebug.c:1465
0000010 0x000000000074ece9 in zend_execute_scripts (type=8, retval=0x0, file_count=3) at /root/php-5.5.11/Zend/zend.c:1316
0000011 0x00000000006f0e49 in php_execute_script (primary_file=0x7fff03256ea0) at /root/php-5.5.11/main/main.c:2506
0000012 0x0000000000807ee2 in main (argc=<value optimized out>, argv=<value optimized out>) at /root/php-5.5.11/sapi/fpm/fpm/fpm_main.c:1933
TagsNo tags attached.
Operating SystemCentos 6.5 X64
PHP Version5.5.5-5.5.9

Activities

derick

2014-05-16 09:28

administrator   ~0002809

Do you have a script to reproduce this?

paulgao

2014-05-19 10:11

reporter   ~0002811

is product servers, too much code, i can't reproduce... :-(

paulgao

2014-05-20 06:35

reporter   ~0002833

I'm sorry, problem founded, is https://github.com/facebook/xhprof/pull/32.

derick

2014-05-20 15:55

administrator   ~0002836

Sorry, but that xhprof thing you linked to doesn't seem to be related at all. At least, when looking at the backtrace. I also didn't quite understand whether you were saying that this was a bug in xhprof, and not in Xdebug?

derick

2014-06-14 10:34

administrator   ~0002852

Unable to reproduce, and no feedback provided. I'm closing this out, but feel free to reopen if you can provide the requested information.

Issue History

Date Modified Username Field Change
2014-05-15 04:31 paulgao New Issue
2014-05-16 09:28 derick Note Added: 0002809
2014-05-16 09:28 derick Assigned To => derick
2014-05-16 09:28 derick Status new => feedback
2014-05-19 10:11 paulgao Note Added: 0002811
2014-05-19 10:11 paulgao Status feedback => assigned
2014-05-20 06:35 paulgao Note Added: 0002833
2014-05-20 15:55 derick Note Added: 0002836
2014-05-20 15:55 derick Status assigned => feedback
2014-06-14 10:34 derick Note Added: 0002852
2014-06-14 10:34 derick Status feedback => resolved
2014-06-14 10:34 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)