View Issue Details

IDProjectCategoryView StatusLast Update
0001062XdebugUsage problems (Wrong Results)public2014-12-15 12:19
ReporterjonycpAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOSWindowsOS Version7
Product Version2.2.5 
Target VersionFixed in Version 
Summary0001062: SimpleXML foreach does not advance during step
DescriptionI have Xampp PHP code that executes correctly, advancing through the foreach loops, but when I try to step through the foreach loops in debug, it hangs and will not advance.

If I put the cursor after the foreach loop and click run to cursor, it will run to cursor.

Problem is happening in foreach loop and cannot debug as needed.
Steps To ReproduceI am using SimpleXML.

$file = simplexml_load_file('file.xml');
$sxo = $file->XML_NODE;

foreach( $sxo as $s ) {
  do something; ==> will not advance through the foreach
}

$variable = value; ==> Set cursor here and Run to Cursor and it runs through the foreach and goes there ok.
Additional Informationfrom php.ini (used wizard / paste phpinfo to get correct version of dll)

[XDebug]
zend_extension = "C:\local-download\xampp\php\ext\php_xdebug-2.2.5-5.5-vc11.dll"
xdebug.profiler_append = 0
xdebug.profiler_enable = 1
xdebug.profiler_enable_trigger = 0
xdebug.profiler_output_dir = "C:\local-download\xampp\tmp\xdebug-logs"
xdebug.profiler_output_name = "cachegrind.out.%t-%s"
xdebug.remote_enable = 1
xdebug.remote_handler = "dbgp"
xdebug.remote_port = 9003
xdebug.remote_host = "127.0.0.1"
xdebug.remote_log = "C:\local-download\xampp\tmp\xdebug-logs\remote.log"
xdebug.trace_output_dir = "C:\local-download\xampp\tmp\xdebug-logs"
xdebug.var_display_max_data=2048
xdebug.idekey="netbeans-xdebug"
TagsNo tags attached.
Operating SystemWindows 7
PHP Version5.5.0-5.5.4

Activities

jonycp

2014-07-08 17:45

reporter   ~0002860

I would like to add, just for reference, that xdebug correctly advances through a foreach loop on a php array.

derick

2014-11-11 19:46

administrator   ~0002890

Can you please provide the script, the XML file and a remote log (see http://xdebug.org/docs/remote#remote_log on how to make one)?

derick

2014-12-13 20:36

administrator   ~0002935

Ping?

jonycp

2014-12-14 13:21

reporter   ~0002937

Hello,

Sorry, for some reason I did not get the email in November. I actually stopped using SimpleXML in favor of a technique I found to using json_encode/decode to create an array. I have no problems debugging an array loop.

Thank you for your follow up on this!

derick

2014-12-15 12:19

administrator   ~0002938

Okay - thanks for the bug report in any case! Let me know if you run into this again.

cheers,
Derick

Issue History

Date Modified Username Field Change
2014-07-08 17:04 jonycp New Issue
2014-07-08 17:45 jonycp Note Added: 0002860
2014-11-11 19:46 derick Note Added: 0002890
2014-11-11 19:46 derick Assigned To => derick
2014-11-11 19:46 derick Status new => feedback
2014-12-13 20:36 derick Note Added: 0002935
2014-12-14 13:21 jonycp Note Added: 0002937
2014-12-14 13:21 jonycp Status feedback => assigned
2014-12-15 12:19 derick Note Added: 0002938
2014-12-15 12:19 derick Status assigned => resolved
2014-12-15 12:19 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)