View Issue Details

IDProjectCategoryView StatusLast Update
0000108XdebugUsage problems (Wrong Results)public2005-01-08 15:21
ReporterkloorAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000108: log_only still displays some text for errors in included files
DescriptionWith PHP run with display_errors = Off, I still get some errant text when an error occurs in an included file. I've tracked the problem down to the block starting on line 1329 of xdebug.c which prints the name of the include without checking the value of log_only.

It works correctly once I add the !log_only condition to the if statement for the block.
Additional InformationI'm actually using PHP 5.0.3 and Xdebug 2.0.0beta2.
TagsNo tags attached.
Operating SystemLinux 2.6
PHP Version5.0.3-dev

Activities

derick

2004-12-21 20:37

administrator   ~0000221

I have a fix for this, but I can not commit this yet because of other non-finished code.

derick

2005-01-08 15:21

administrator   ~0000222

Fixed in CVS

Issue History

Date Modified Username Field Change
2004-12-21 19:19 kloor New Issue
2004-12-21 20:37 derick Note Added: 0000221
2005-01-08 15:21 derick Status new => closed
2005-01-08 15:21 derick Note Added: 0000222
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)