View Issue Details

IDProjectCategoryView StatusLast Update
0001080XdebugUsage problems (Wrong Results)public2017-01-03 18:43
Reporterboen_robotAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformTravis-CIOSLinuxOS Version
Product Version2.2.5 
Target VersionFixed in Version 
Summary0001080: Code coverage causes timeout for stream_socket_accept
DescriptionI have a project that wraps around stream_socket_server() and stream_socket_client(), and I run tests on Travis-CI for it.

Its PHPUnit tests run fine, until I turn on code coverage, at which point the server can't accept a connection from the client with stream_socket_accept(), and just times out.

This does NOT happen on Windows, and I don't have access to any Linux machine other than Travis-CI to confirm whether it happens there too (and for some reason, I can't install Ubuntu on a VirtualBox VM either...).

You can see the failed build here:
https://travis-ci.org/pear2/Net_Transmitter/builds/39101957
and you can see the last successful one here:
https://travis-ci.org/pear2/Net_Transmitter/builds/39095835

(notice the missing "--coverage-clover=coverage.clover"; There aren't any changes within the code under test between those two)
Tagspear, SERVER
Operating System
PHP Version5.5.5-5.5.9

Activities

derick

2016-12-03 12:49

administrator   ~0003877

If you can still reproduce this yourself, could you provide me with the exact steps to run this locally to reproduce the problem? Without that, it is unlikely that I can find and fix the bug.

cheers,
Derick

derick

2017-01-03 18:43

administrator   ~0004115

I could not reproduce this, as there was no reproducible case, and no additional information was presented. I am therefore closing this report.

Issue History

Date Modified Username Field Change
2014-10-26 22:31 boen_robot New Issue
2014-10-26 22:32 boen_robot Tag Attached: pear
2014-10-26 22:32 boen_robot Tag Attached: SERVER
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-03 12:49 derick Note Added: 0003877
2016-12-03 12:49 derick Assigned To => derick
2016-12-03 12:49 derick Status new => feedback
2017-01-03 18:43 derick Note Added: 0004115
2017-01-03 18:43 derick Status feedback => resolved
2017-01-03 18:43 derick Resolution open => fixed
2017-01-03 18:43 derick Resolution fixed => unable to reproduce