View Issue Details

IDProjectCategoryView StatusLast Update
0001082XdebugUsage problems (Wrong Results)public2014-12-13 20:33
ReporterDemonTPxAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.2.3 
Target VersionFixed in Version2.2.7 
Summary0001082: Segmentation fault when using php-couchbase
DescriptionPHP segfaults when both xdebug and couchbase (version 2.0.0) extensions are loaded
Steps To Reproducephp -n -d zend_extension=xdebug.so -d extension=couchbase.so
Additional Information$ gdb --args php -n -d zend_extension=xdebug.so -d extension=couchbase.so
GNU gdb (Ubuntu 7.7-0ubuntu3.1) 7.7
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from php...Reading symbols from /usr/lib/debug//usr/bin/php5...done.
done.
(gdb) run
Starting program: /usr/bin/php -n -d zend_extension=xdebug.so -d extension=couchbase.so
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff575a4ce in xdebug_execute_internal (current_execute_data=0x7ffff7fa9640, fci=0x0, return_value_used=0)
    at /build/buildd/xdebug-2.2.3/xdebug-2.2.3/xdebug.c:1589
1589 /build/buildd/xdebug-2.2.3/xdebug-2.2.3/xdebug.c: No such file or directory.
(gdb) bt
#0 0x00007ffff575a4ce in xdebug_execute_internal (current_execute_data=0x7ffff7fa9640, fci=0x0, return_value_used=0)
    at /build/buildd/xdebug-2.2.3/xdebug-2.2.3/xdebug.c:1589
#1 0x000000000079da25 in zend_do_fcall_common_helper_SPEC (execute_data=<optimized out>) at /build/buildd/php5-5.5.9+dfsg/Zend/zend_vm_execute.h:552
0000002 0x0000000000717758 in execute_ex (execute_data=0x7ffff7fa9640) at /build/buildd/php5-5.5.9+dfsg/Zend/zend_vm_execute.h:363
0000003 0x00000000006dd8c9 in dtrace_execute_ex (execute_data=<optimized out>) at /build/buildd/php5-5.5.9+dfsg/Zend/zend_dtrace.c:73
0000004 0x00007ffff5759a7c in xdebug_execute_ex (execute_data=0x7ffff7fa9640) at /build/buildd/xdebug-2.2.3/xdebug-2.2.3/xdebug.c:1437
0000005 0x00000000006e175a in zend_eval_stringl (
    str=0x7ffff5540b40 "/**\n * Various constants used for flags, data-type encoding and decoding, etc...\n * throughout this SDK.\n *\n * @author Brett Lawson <brett19@gmail.com>\n */\n\n/** @internal */ define('COUCHBASE_VAL_MASK"..., str_len=<optimized out>, retval_ptr=retval_ptr@entry=0x0,
    string_name=string_name@entry=0x7ffff5540abb "CouchbaseNative") at /build/buildd/php5-5.5.9+dfsg/Zend/zend_execute_API.c:1187
0000006 0x00000000006e1836 in zend_eval_string (str=<optimized out>, retval_ptr=retval_ptr@entry=0x0, string_name=string_name@entry=0x7ffff5540abb "CouchbaseNative")
    at /build/buildd/php5-5.5.9+dfsg/Zend/zend_execute_API.c:1226
0000007 0x00007ffff553c97c in zm_activate_couchbase (type=<optimized out>, module_number=<optimized out>) at /tmp/pear/temp/couchbase/couchbase.c:63
0000008 0x00000000006f4dc0 in zend_activate_modules () at /build/buildd/php5-5.5.9+dfsg/Zend/zend_API.c:2398
0000009 0x000000000068d8ea in php_request_startup () at /build/buildd/php5-5.5.9+dfsg/main/main.c:1596
0000010 0x000000000079f1b1 in do_cli (argc=6, argv=0xebea10) at /build/buildd/php5-5.5.9+dfsg/sapi/cli/php_cli.c:965
0000011 0x0000000000461de0 in main (argc=6, argv=0xebea10) at /build/buildd/php5-5.5.9+dfsg/sapi/cli/php_cli.c:1378
(gdb)
TagsNo tags attached.
Operating SystemUbuntu 14.04.1
PHP Version5.5.5-5.5.9

Relationships

duplicate of 0001087 closedderick Segmentation Fault when calling zend_eval_string from RINIT 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-10-31 09:49 DemonTPx New Issue
2014-12-13 20:33 derick Relationship added duplicate of 0001087
2014-12-13 20:33 derick Status new => resolved
2014-12-13 20:33 derick Fixed in Version => 2.2.7
2014-12-13 20:33 derick Resolution open => duplicate
2014-12-13 20:33 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)