View Issue Details

IDProjectCategoryView StatusLast Update
0001115XdebugUsage problems (Wrong Results)public2015-02-26 11:25
ReporterpondermaticAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformOSWindowsOS Version7
Product Version2.3.0 
Target VersionFixed in Version 
Summary0001115: Profiler does not output filename or function values
DescriptionThe profiler output file is missing many fl/fn and cfl/cfn values.
Steps To ReproduceProfile any PHP script.
Additional InformationHere is the cachegrind.out from a script with phpinfo().

version: 1
creator: xdebug 2.3.0
cmd: E:\Builds\Phalcon\public\phpinfo.php
part: 1
positions: line

events: Time

fl=(1) php:internal
fn=(1) php::phpinfo
2 8000

fl=(2) E:\Builds\Phalcon\public\phpinfo.php
fn=(2) {main}

summary: 9001

1 1000
cfl=(1)
cfn=(1)
calls=1 0 0
2 8000

------------
And here is the same script with Xdebug 2.2.7.

version: 1
creator: xdebug 2.2.7
cmd: E:\Builds\Phalcon\public\phpinfo.php
part: 1
positions: line

events: Time

fl=php:internal
fn=php::phpinfo
2 7000

fl=E:\Builds\Phalcon\public\phpinfo.php
fn={main}

summary: 7000

1 0
cfl=php:internal
cfn=php::phpinfo
calls=1 0 0
2 7000

TagsNo tags attached.
Operating System
PHP Version5.6.5-5.6.9

Activities

derick

2015-02-24 19:45

administrator   ~0003001

This is not a bug, but deliberate. The duplicated file and function names have been replaced by (1) etc. The cachegrind format supports "file name" and "function name" compression, for which I have added support in Xdebug 2.3.

http://valgrind.org/docs/manual/cl-format.html#cl-format.overview.compression1

pondermatic

2015-02-25 22:04

reporter   ~0003002

The "file name" and "function name" compression is a great feature. Unfortunately the latest version of WinCacheGrind that I can find, https://github.com/ceefour/wincachegrind/releases/tag/1.0.0.15. doesn't support it. Today I switched over to QCacheGrind from http://sourceforge.net/projects/qcachegrindwin/. Works great!

Maybe http://xdebug.com/docs/profiler should mention the compression feature and compatibility with WinCacheGrind and QCacheGrind. Or perhaps there should be a setting to turn off the compression feature?

derick

2015-02-26 11:25

administrator   ~0003003

I had already filed an issue for PHP Storm: https://youtrack.jetbrains.com/issue/WI-26466

And have now also done one for wincachegrind: https://github.com/ceefour/wincachegrind/issues/1

I have also updated the instructions at http://xdebug.org/docs/profiler

Issue History

Date Modified Username Field Change
2015-02-24 19:38 pondermatic New Issue
2015-02-24 19:45 derick Note Added: 0003001
2015-02-24 19:45 derick Status new => resolved
2015-02-24 19:45 derick Resolution open => no change required
2015-02-24 19:45 derick Assigned To => derick
2015-02-25 22:04 pondermatic Note Added: 0003002
2015-02-25 22:04 pondermatic Status resolved => feedback
2015-02-25 22:04 pondermatic Resolution no change required => reopened
2015-02-26 11:25 derick Note Added: 0003003
2015-02-26 11:25 derick Status feedback => resolved
2015-02-26 11:25 derick Resolution reopened => no change required
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)