View Issue Details

IDProjectCategoryView StatusLast Update
0001136XdebugUsage problems (Wrong Results)public2015-05-30 20:03
ReporterSAbboushiAssigned Toderick 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionsuspended 
PlatformWindowsOSWindowsOS VersionW764
Product Version2.3.2 
Target VersionFixed in Version 
Summary0001136: Revisit: Property access is not allowed yet re: mysqli
DescriptionA breakpoint that evaluates mysqli methods after a failed connection generates 262 * 4 entries in php_error.log and crashes the debug session.

It seems this matter was reported in "0000900: Logs filled with spurious warnings" with resolution "not fixable" [because it is a mysqli driver bug].

My frustration led me to try Zend Studio/zend debugger. I wonder how their debugger overcomes the problem...? No problems whatsoever with the same php code...
TagsNo tags attached.
Operating SystemW764
PHP Version5.6.5-5.6.9

Activities

derick

2015-05-30 20:03

administrator   ~0003098

I don't know how the Zend debugger fixes it, as it is not open source. I am not sure what to do, as the bug in the MySQLi extension is still present.

Issue History

Date Modified Username Field Change
2015-04-06 21:55 SAbboushi New Issue
2015-05-30 20:03 derick Note Added: 0003098
2015-05-30 20:03 derick Status new => resolved
2015-05-30 20:03 derick Resolution open => suspended
2015-05-30 20:03 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)