View Issue Details

IDProjectCategoryView StatusLast Update
0001139XdebugInstallationpublic2015-04-10 21:02
ReporteryaustinovAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.3.2 
Target VersionFixed in Version 
Summary0001139: Failed loading xdebug.so after php update
DescriptionAfter I upgraded PHP to version 5.6.7, xdebug doesn't work anymore.

The error is occured after every php launch:
Failed loading /home/user/xdebug-2.3.2/modules/xdebug.so: /home/user/xdebug-2.3.2/modules/xdebug.so: undefined symbol: sapi_globals_id

I had xdebug v2.2.7 when it was happened the first time (immediately after php updgrade). After that, I downloaded newest version of xdebug and installed it from source according instructions from the site. But nothing has changed :(
Additional Informationcat /proc/version
Linux version 3.2.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.65-1

php -v
PHP 5.6.7-1~dotdeb.2 (cli) (built: Mar 26 2015 00:07:43)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
    with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2015, by Zend Technologies
TagsNo tags attached.
Operating SystemDebian 4.6.3-14
PHP Version5.6.5-5.6.9

Activities

derick

2015-04-10 21:02

administrator   ~0003066

Sorry, this is not a bug. You need to make sure that you compile Xdebug against the right headers. If you need support, please contact the support list: http://xdebug.org/support.php#list

Issue History

Date Modified Username Field Change
2015-04-09 14:11 yaustinov New Issue
2015-04-10 21:02 derick Note Added: 0003066
2015-04-10 21:02 derick Status new => resolved
2015-04-10 21:02 derick Resolution open => no change required
2015-04-10 21:02 derick Assigned To => derick