View Issue Details

IDProjectCategoryView StatusLast Update
0001162XdebugInstallationpublic2017-01-03 18:44
ReporterRukienAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status resolvedResolutionunable to reproduce 
PlatformWindowsOSWindowsOS VersionServer 2008 R2
Product Version2.3.2 
Target VersionFixed in Version 
Summary0001162: php5ts.dll crashes with xdebug enabled
DescriptionHello,

I'm facing a strange issue. I configured a web server up-to-date with Apache 5.6.24, MySQL5.6.24, PHP 5.6.10 on Windows Server 2008 R2 Standard.

I've copied two PHP apps from my old server to the newest which worked like a charm, but the third makes PHP crash. As PHP is loaded as an Apache modules, it also make apache restart.

Windows Event log says that php5ts.dll has failed (see additionnal informations).

I tried to unable some PHP extensions, but it has no effect, until I disabled xdebug.

I Downgraded xdebug to 2.2.7 and then 2.2.5, but it didn't fixed it.

If I can help by giving more infos, don't hesitate !
Steps To ReproduceI cannot give you steps :
Basically I try to connect to the app with a web browser and it makes php crash.
Additional InformationServer config :
Windows 2008 R2 Standard
Apache 2.4.12 32bits VC11
MySQL 5.6.24 64bits
PHP 5.6.10 32bits (bug also occured with 5.6.8) VC11

Xdebug 2.3.2 5.6 VC11 32 bits


apache error log :
[Wed Jun 17 10:29:16.252977 2015] [mpm_winnt:notice] [pid 1072:tid 564] AH00428: Parent: child process 1452 exited with status 255 -- Restarting.
[Wed Jun 17 10:29:16.658707 2015] [mpm_winnt:notice] [pid 1072:tid 564] AH00455: Apache/2.4.12 (Win32) mod_authn_ntlm/1.0.0 PHP/5.6.10 configured -- resuming normal operations
[Wed Jun 17 10:29:16.658707 2015] [mpm_winnt:notice] [pid 1072:tid 564] AH00456: Server built: Mar 19 2015 18:23:40
[Wed Jun 17 10:29:16.658707 2015] [mpm_winnt:notice] [pid 1072:tid 564] AH80000: Distributed by: The Apache Haus
[Wed Jun 17 10:29:16.658707 2015] [mpm_winnt:notice] [pid 1072:tid 564] AH80001: Compiled with: Visual Studio 2008
[Wed Jun 17 10:29:16.658707 2015] [core:notice] [pid 1072:tid 564] AH00094: Command line: 'C:\\Apache24\\bin\\httpd.exe -d C:/Apache24'
[Wed Jun 17 10:29:16.658707 2015] [mpm_winnt:notice] [pid 1072:tid 564] AH00418: Parent: Created child process 2864

Windows event log :
Nom de l’application défaillante httpd.exe, version : 2.4.12.0, horodatage : 0x550b7a15
Nom du module défaillant : php5ts.dll, version : 5.6.10.0, horodatage : 0x5578c6e7
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000a7af
ID du processus défaillant : 0x5ac
Heure de début de l’application défaillante : 0x01d0a8d7a7f0def1
Chemin d’accès de l’application défaillante : C:\Apache24\bin\httpd.exe
Chemin d’accès du module défaillant: C:\php5.6.10\php5ts.dll
ID de rapport : efccc181-14ca-11e5-b3ec-000c2934de47
TagsNo tags attached.
Operating SystemWindows Server 2008 R2
PHP Version5.6.5-5.6.9

Activities

unknownbrackets

2015-06-25 03:19

reporter   ~0003129

Can you try reducing the test case? For example, let's say it crashes in index.php.

If you make index.php start with the following, does it still crash?

<?php

echo 'hi there';
die;

?>

If this doesn't crash, how low can you move the die; before it does crash?

If you can remove a bunch of code from possibly being the problem, you might be able to narrow it down to a small chunk of code (like just one file you include) that causes it. This might be something you could upload, so other people can reproduce it and possibly fix it.

Unfortunately, just knowing that it can crash when pointed at certain PHP code probably won't lead to a fix very directly or soon. It's sorta like knowing there's a typo somewhere in a bookcase full of books. Sounds pretty believable (there's likely more than just one, in fact), but it's hard to find without more info than that.

-[Unknown]

Rukien

2015-07-07 12:36

reporter   ~0003147

Hi,

Here's an example of "buggy code". I isolated it by using die() calls on the source code. It's extracted from a function :

$res = database::$db->fetch_result($stmt, 'ROW');
        
echo '<h2>get_Acces Test 2 post query</h2>';
var_dump($res); //displays the expected value
//die(); //it works

if($res[0][0] > -1) {
    ...code...
    return true; //it fails (won't be returned)
} else {
    echo '<h3> test superieur a -1</h3>';
        // die(); //it works
    return false; //it fails (won't be returned)
}

It seems that the function works properly but its the return keyword seems to fail : when I try to get the result of this function, it crashes. Same error as above. I've upgraded xdebug in 2.3.3, same error. It is not the first function called in the script, the other ones are running properly.

If I find another case like this one where it crash, I'll report it.

derick

2016-12-03 13:19

administrator   ~0003880

Can you still reproduce this with PHP 5.6.28, and Xdebug 2.5.0RC1? Or is this no longer an issue for you?

derick

2017-01-03 18:44

administrator   ~0004117

I could not reproduce this, as there was no reproducible case, and no additional information was presented. I am therefore closing this report.

Issue History

Date Modified Username Field Change
2015-06-17 12:31 Rukien New Issue
2015-06-25 03:19 unknownbrackets Note Added: 0003129
2015-07-07 12:36 Rukien Note Added: 0003147
2016-12-03 13:19 derick Note Added: 0003880
2016-12-03 13:19 derick Assigned To => derick
2016-12-03 13:19 derick Status new => feedback
2017-01-03 18:44 derick Note Added: 0004117
2017-01-03 18:44 derick Status feedback => resolved
2017-01-03 18:44 derick Resolution open => unable to reproduce