View Issue Details

IDProjectCategoryView StatusLast Update
0000117XdebugUsage problems (Wrong Results)public2005-03-10 22:36
ReporterakorthausAssigned To 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000117: var_dump dows not work with "private"
DescriptionI have the following code:

<?php
class Test {
    private $test;
}
var_dump (new Test);
?>

without xdebug I geht the following output:

object(Test)0000011 (1) {
  ["test:private"]=>
  NULL
}

with xdebug enabled, I get:

object(Test)
  '' => null

The same for "protected". "public" works correct.
TagsNo tags attached.
Operating SystemLinux 2.4.28 (Gentoo)
PHP Version5.0.3-dev

Activities

akorthaus

2005-02-17 14:09

reporter   ~0000234

in xdebug-2.0.0beta2 this problem seems to be solved

derick

2005-03-10 22:36

administrator   ~0000246

Fixed in CVS (XDEBUG_1_3), this fix was already in HEAD (for Xdebug 2.0)

Issue History

Date Modified Username Field Change
2005-02-16 13:50 akorthaus New Issue
2005-02-17 14:09 akorthaus Note Added: 0000234
2005-03-10 22:36 derick Status new => closed
2005-03-10 22:36 derick Note Added: 0000246
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)