View Issue Details

IDProjectCategoryView StatusLast Update
0001176Xdebug(No Category)public2015-11-20 17:51
ReportertomcastlemanAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformGNU/Linux x86_64OSUbuntu OS Version14.04.3 LTS
Product Version2.3.2 
Target VersionFixed in Version 
Summary0001176: SIGSEGV, Segmentation fault
DescriptionI am inserting multiple rows in one PDO statement to MySQL. When one of those rows triggers a database error (duplicate key for example) php5-fpm throws a SIGSEGV when the total rows is larger than a certain size.

Looking at the core dump (attached) it seems xdebug is the cause. With xdebug disabled there is no issue.

PHP Version: 5.6.11+dfsg-1+deb.sury.org~trusty+1
XDebug Version: 2.3.2
pdo_mysql client API version => mysqlnd 5.0.11-dev - 20120503
Steps To Reproduce- Execute a multi insert statement "INSERT INTO x VALUES (), (), ()" where at least one row will trigger a duplicate key, and with a large number of total rows
- A PDOException is thrown (in my case I am using illuminate/database and a Illuminate\\Database\\QueryException is thrown as seen in the trace) however php5-fpm seg faults.
- Decreasing the number of total rows in the insert sometimes resolves the issue.
TagsNo tags attached.
Operating SystemUbunbu 14.04.3
PHP Version5.6-dev

Activities

tomcastleman

2015-08-11 12:07

reporter  

php5-trace.log (5,976 bytes)

derick

2015-10-23 08:29

administrator   ~0003189

Can you provide a full short script that reproduces this?

derick

2015-11-05 15:17

administrator   ~0003201

Ping?

derick

2015-11-20 17:51

administrator   ~0003244

Can't reproduce this, and no feedback provided.

Issue History

Date Modified Username Field Change
2015-08-11 12:07 tomcastleman New Issue
2015-08-11 12:07 tomcastleman File Added: php5-trace.log
2015-10-23 08:29 derick Note Added: 0003189
2015-10-23 08:29 derick Assigned To => derick
2015-10-23 08:29 derick Status new => feedback
2015-11-05 15:17 derick Note Added: 0003201
2015-11-20 17:51 derick Note Added: 0003244
2015-11-20 17:51 derick Status feedback => resolved
2015-11-20 17:51 derick Resolution open => unable to reproduce
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)