View Issue Details

IDProjectCategoryView StatusLast Update
0001178XdebugUsage problems (Wrong Results)public2016-12-04 22:00
ReporterhwdeAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformApple MacOSOS XOS Version10.10.4
Product Version 
Target VersionFixed in Version 
Summary0001178: crash on cleanup kills apache child process
DescriptionLoading PHP-Webpages with Chrome which contains a could of Ajax requests to the same (local) Apache-Webserver seems to crash the apache child process. Disableing xdebug fix the issue (no crash). This happens only on with few on local vhosts, others, without ajax requests runs just fine. It doens't matter which php-version is in use, 5.4, 5.5 or 5.6 all behaves the same.
Steps To ReproduceEasy on my desktop, but havn't yet tried to extract the php-calls to strip it down to an example.
Additional InformationAttached you'll find a apache backtrace.
TagsNo tags attached.
Operating SystemOS X 10.10.4, up-to-date Apache with MacPorts
PHP Version5.6.0-5.6.4

Activities

hwde

2015-08-13 09:21

reporter  

xdebug-crash (2,766 bytes)
Process 59376 stopped
* thread #1: tid = 0x451b02, 0x00007fff81571286 libsystem_kernel.dylib`__pthread_kill + 10, queue = 'com.apple.main-thread', stop reason = signal SIGABRT
    frame #0: 0x00007fff81571286 libsystem_kernel.dylib`__pthread_kill + 10
libsystem_kernel.dylib`__pthread_kill:
->  0x7fff81571286 <+10>: jae    0x7fff81571290            ; <+20>
    0x7fff81571288 <+12>: movq   %rax, %rdi
    0x7fff8157128b <+15>: jmp    0x7fff8156cc53            ; cerror_nocancel
    0x7fff81571290 <+20>: retq   
(lldb) bt
* thread #1: tid = 0x451b02, 0x00007fff81571286 libsystem_kernel.dylib`__pthread_kill + 10, queue = 'com.apple.main-thread', stop reason = signal SIGABRT
  * frame #0: 0x00007fff81571286 libsystem_kernel.dylib`__pthread_kill + 10
    frame #1: 0x00007fff840d342f libsystem_pthread.dylib`pthread_kill + 90
    frame #2: 0x00007fff84d60bf3 libsystem_c.dylib`__abort + 145
    frame #3: 0x00007fff84d614d1 libsystem_c.dylib`__stack_chk_fail + 197
    frame #4: 0x0000000103355778 xdebug.so`xdebug_create_socket + 704
    frame #5: 0x0000000103360466 xdebug.so`xdebug_init_debugger + 300
    frame #6: 0x0000000103350b3b xdebug.so`xdebug_execute + 1439
    frame #7: 0x0000000102b6fb80 mod_php54.so`zend_call_function + 1853
    frame #8: 0x0000000102b8ed67 mod_php54.so`zend_call_method + 623
    frame #9: 0x0000000102b98384 mod_php54.so`zend_objects_destroy_object + 412
    frame #10: 0x0000000102b9d6ce mod_php54.so`zend_objects_store_call_destructors + 100
    frame #11: 0x0000000102b6e2fb mod_php54.so`shutdown_destructors + 165
    frame #12: 0x0000000102b7b39e mod_php54.so`zend_call_destructors + 74
    frame #13: 0x0000000102b25492 mod_php54.so`php_request_shutdown + 170
    frame #14: 0x0000000102c0a32e mod_php54.so`php_handler + 1333
    frame #15: 0x0000000102243c39 httpd`ap_run_handler + 43
    frame #16: 0x00000001022440ab httpd`ap_invoke_handler + 247
    frame #17: 0x000000010226228a httpd`ap_internal_redirect + 54
    frame #18: 0x00000001029a4a5f mod_rewrite.so`handler_redirect + 128
    frame #19: 0x0000000102243c39 httpd`ap_run_handler + 43
    frame #20: 0x00000001022440ab httpd`ap_invoke_handler + 247
    frame #21: 0x0000000102261f3d httpd`ap_process_request + 83
    frame #22: 0x000000010225f907 httpd`ap_process_http_connection + 118
    frame #23: 0x000000010224f6af httpd`ap_run_process_connection + 43
    frame #24: 0x0000000102267bc0 httpd`child_main + 803
    frame #25: 0x0000000102267237 httpd`make_child + 207
    frame #26: 0x00000001022672f6 httpd`startup_children + 73
    frame #27: 0x000000010226693c httpd`ap_mpm_run + 1209
    frame #28: 0x0000000102248f9b httpd`main + 2307
    frame #29: 0x00007fff840cd5c9 libdyld.dylib`start + 1
    frame #30: 0x00007fff840cd5c9 libdyld.dylib`start + 1
xdebug-crash (2,766 bytes)

hwde

2015-08-13 09:23

reporter   ~0003159

I forget to paste the message from apache error-log:
[Thu Aug 13 10:31:15 2015] [notice] child pid 4854 exit signal Abort trap (6)

derick

2016-12-03 13:21

administrator   ~0003881

Is this still a problem with the latest PHP (5.6.28) and Xdebug (2.5.0RC1)?

hwde

2016-12-04 21:23

reporter   ~0003936

No, it seems to be fixed in the meantime, neither 7.0.13 or 5.6.28.

derick

2016-12-04 22:00

administrator   ~0003937

Perfect, let me close this then.

Thanks for coming back to me!

Issue History

Date Modified Username Field Change
2015-08-13 09:21 hwde New Issue
2015-08-13 09:21 hwde File Added: xdebug-crash
2015-08-13 09:23 hwde Note Added: 0003159
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-03 13:21 derick Note Added: 0003881
2016-12-03 13:21 derick Assigned To => derick
2016-12-03 13:21 derick Status new => feedback
2016-12-04 21:23 hwde Note Added: 0003936
2016-12-04 21:23 hwde Status feedback => assigned
2016-12-04 22:00 derick Note Added: 0003937
2016-12-04 22:00 derick Status assigned => resolved
2016-12-04 22:00 derick Resolution open => no change required