View Issue Details

IDProjectCategoryView StatusLast Update
0001184XdebugUsage problems (Wrong Results)public2017-01-03 18:44
ReportergggeekAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformubuntu12+php5.6, win8.1+php5.5OSOS Version
Product Version2.3.3 
Target VersionFixed in Version 
Summary0001184: core dump while generating code coverage of a phpunit test suite
DescriptionThe app is a Symfony bundle used to interact with Rabbitmq (via pure php code, not the amqplib extension).

Crash reproduced with:
- Travis VM (Ubuntu 12.04) + php 5.6.5 + Xdebug 2.2.7 (native), 2.3.2 (pecl), 2.3.3 (compiled)
- Win 8.1 64bit + php 5.5.27, 5.5.29 (vc11ts32bit) + Xdebug 2.3.3

The Travis builds are at https://travis-ci.org/kaliop-uk/kueueingbundle/builds - the ones running xdebug with code-coverage are the one on php 5.5 (even the recent green ones are in fact failing).

Running the same test suite without code coverage, the test suite has no problems (both on linux and windows).

I tried increasing memory for phpunit to 2GB, but it did not help. Not sure if there is any other tunable I can tweak.
Steps To Reproducegit clone git@github.com:kaliop-uk/kueueingbundle.git
composer install
phpunit --coverage-clover=coverage.clover Tests/phpunit
TagsNo tags attached.
Operating Systemlinux + windows
PHP Version5.6.10-5.6.14

Activities

gggeek

2015-09-11 23:27

reporter   ~0003173

ps: both in Travis and locally, phpunit version in use is 4.8.6

gggeek

2015-09-11 23:35

reporter   ~0003174

ps: seems very similar to bug 0001180

gggeek

2015-09-12 19:15

reporter   ~0003175

Further tests: on windows, tested Xdebug versions 2.2 to 2.6 (as in bug 1180 version 2.2.4 was mentioned to be ok), and they all crash.
The crash happens in the phpunit phase where it says 'Generating code coverage report in whatever format ...' - for both clover and html formats

derick

2016-12-03 13:28

administrator   ~0003883

Is this still a problem for you? I've tried reproducing this, but your test case's composer dependencies seem broken:

derick@whisky:/tmp/kueueingbundle $ php ~/composer.phar install
You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for codeclimate/php-test-reporter ^0.2 -> satisfiable by codeclimate/php-test-reporter[v0.2.0].
    - codeclimate/php-test-reporter v0.2.0 requires satooshi/php-coveralls 0.6.* -> satisfiable by satooshi/php-coveralls[v0.6.0, v0.6.1].
    - satooshi/php-coveralls v0.6.0 requires psr/log 1.0.0 -> satisfiable by psr/log[1.0.0].
    - satooshi/php-coveralls v0.6.1 requires psr/log 1.0.0 -> satisfiable by psr/log[1.0.0].
    - Conclusion: don't install psr/log 1.0.0

derick

2017-01-03 18:44

administrator   ~0004118

I could not reproduce this, as there was no reproducible case, and no additional information was presented. I am therefore closing this report.

Issue History

Date Modified Username Field Change
2015-09-11 23:27 gggeek New Issue
2015-09-11 23:27 gggeek Note Added: 0003173
2015-09-11 23:35 gggeek Note Added: 0003174
2015-09-12 19:15 gggeek Note Added: 0003175
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-03 13:28 derick Note Added: 0003883
2016-12-03 13:28 derick Assigned To => derick
2016-12-03 13:28 derick Status new => feedback
2017-01-03 18:44 derick Note Added: 0004118
2017-01-03 18:44 derick Status feedback => resolved
2017-01-03 18:44 derick Resolution open => unable to reproduce