View Issue Details

IDProjectCategoryView StatusLast Update
0000122XdebugUsage problems (Wrong Results)public2006-01-17 21:28
ReporteralisencerAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version 
Target VersionFixed in Version 
Summary0000122: Profiling problems with serendipity
DescriptionThe cachegrind file that is generated is faulty and contains invalid characters (Ultraedit shows lots of blank lines - but also changes size of scroll bar while scrolling. less shows lots of ^@). Here is an example:

www.sencer.de/code/cachegrind.out.3863005622.txt.gz

These files cannot be opened with KCachegrind (on Cygwin; it freezes) nor WinCachegrind (errormsg pointing to the respective line 8565).

This only happens when profiling serendipity ( www.s9y.org ). Other Scripts work fine.

Additional InformationWindowsXP SP2, Apache 1.3.29, PHP 4.3.10 (not dev).
TagsNo tags attached.
Operating SystemWindows XP
PHP Version4.3.10-dev

Activities

nsharp

2005-07-03 18:56

reporter   ~0000264

I get the exact same symptoms, but am trying to profile the SyncML interface to horde (Horde.org). The bad characters it adds are NULL characters (ascii 0) and there are sometimes megabytes of them. I wrote a quick perl script to drop the NULLs out, and the files now load in kcachegrind, but the values are bogus and there are may obvious things wrong with the results.

I have tried both 2.0.0beta2 and also CVS HEAD as of sometime last week.

System: Mandriva 10.0
Apache: 2.0.48
PHP: 4.3.4
Horde: CVS Head as of a few weeks ago

This is a show-stopper for me.

nsharp

2005-07-27 18:32

reporter   ~0000267

I found the problem for me. It turns out that my SyncML client was making several connections in a row in order to process the request. Since XDebug creates a single file for all requests to the same directory, and since apache is multi-threaded, there were several threads competing to write to the file. I threw in a dirty hack to make it create a new filename on each request and I get several files that are all correct without any NULLs.

derick

2006-01-17 21:28

administrator   ~0000338

This is not something I can fix... you can select Xdebug to create a file per-pid ofcourse.

Issue History

Date Modified Username Field Change
2005-03-28 22:39 alisencer New Issue
2005-07-03 18:56 nsharp Note Added: 0000264
2005-07-27 18:32 nsharp Note Added: 0000267
2006-01-17 21:28 derick Status new => resolved
2006-01-17 21:28 derick Resolution open => not fixable
2006-01-17 21:28 derick Assigned To => derick
2006-01-17 21:28 derick Note Added: 0000338
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)