View Issue Details

IDProjectCategoryView StatusLast Update
0001226XdebugUsage problems (Wrong Results)public2016-12-04 17:39
ReporterbseddonAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.4.0rc2 
Target VersionFixed in Version 
Summary0001226: Is it possible to fill the Eclipse 'Parameter Stack' view
DescriptionIn Ecplise, at least when using ZendDebugger, the 'Parameter Stack' view shows all variables in scope at the breakpoint and their respective values. When I use XDebug this view is empty. Is there a XDebug configuration setting I can use to populate this view?

Thanks
TagsNo tags attached.
Operating System
PHP Version7.0.0rc7

Activities

derick

2015-12-10 14:59

administrator   ~0003312

On which platform are you?

bseddon

2015-12-10 16:37

reporter   ~0003316

OS: Windows 2012
Eclipse: Nano
PDT: 3.7

derick

2015-12-12 21:32

administrator   ~0003329

I just released Xdebug 2.4.0RC3, which hopefully addresses stability issues on Windows: http://xdebug.org/#2015_12_12 — Can you please try that? Make also sure you run this with PHP 7.0.0 (or later), and not a PHP 7 Release Candidate.

In case it does not solve the problem, please provide a *full* but *short* reproducible test case that I can run myself. That includes hopefully a *single* script, and an accompanying remote debugging log (which you can make by setting xdebug.remote_log=c:\windows\temp\xdebug.log in php.ini).

bseddon

2015-12-12 22:47

reporter   ~0003333

No, it makes no difference. But I thought maybe there will be an xdebug.xxx option that might make them appear.

derick

2015-12-13 20:54

administrator   ~0003334

No, there is no option. This should always work. Can you please do the following:

1. write a tiny script, with one or two functions passing in one or two arguments and setting (calculating) some maths things and store them as other arguments in the function.
2. Make the setting "xdebug.remote_log=C:\Windows\Temp\xdebug.log" in php.ini
3. Try to step through this tiny script
4. Attach the tiny script and the resulting xdebug.log file to this report.

bseddon

2015-12-13 21:01

reporter   ~0003335

Hi Derick

How about using the log associated with my other issue report http://bugs.xdebug.org/view.php?id=1223?

That post includes a three line script and the corresponding log files.

The parameter stack view is not populated with anything ever when using XDebug PHP 7.0. At the risk stating the obvious, this parameter stack view is filled when using PHP 5.x.

derick

2016-12-04 15:11

administrator   ~0003897

Hi,

is this still causing an issue for you? I've not heard anybody else complain about this either.

cheers,
Derick

bseddon

2016-12-04 15:52

reporter   ~0003910

Hi Derick

Although the Eclipse PDT on-line documentation shows the view should exists (http://www.eclipse.org/pdt/help/html/parameter_stack.htm) the view is not available in Eclipse Neon with PDT 4.1.0 because it has been removed (https://bugs.eclipse.org/bugs/show_bug.cgi?id=492010).

My guess the reason I was not able to see the view populate is that support for the view was being withdrawn and not supported.

Regards

Bill

derick

2016-12-04 17:39

administrator   ~0003926

Okay - thanks for letting me know. I'll be closing this then.

Issue History

Date Modified Username Field Change
2015-12-07 18:07 bseddon New Issue
2015-12-10 14:59 derick Note Added: 0003312
2015-12-10 14:59 derick Assigned To => derick
2015-12-10 14:59 derick Status new => feedback
2015-12-10 16:37 bseddon Note Added: 0003316
2015-12-10 16:37 bseddon Status feedback => assigned
2015-12-12 21:32 derick Note Added: 0003329
2015-12-12 21:32 derick Status assigned => feedback
2015-12-12 22:47 bseddon Note Added: 0003333
2015-12-12 22:47 bseddon Status feedback => assigned
2015-12-13 20:54 derick Note Added: 0003334
2015-12-13 20:54 derick Status assigned => feedback
2015-12-13 21:01 bseddon Note Added: 0003335
2015-12-13 21:01 bseddon Status feedback => assigned
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-04 15:11 derick Note Added: 0003897
2016-12-04 15:11 derick Status assigned => feedback
2016-12-04 15:52 bseddon Note Added: 0003910
2016-12-04 15:52 bseddon Status feedback => assigned
2016-12-04 17:39 derick Note Added: 0003926
2016-12-04 17:39 derick Status assigned => resolved
2016-12-04 17:39 derick Resolution open => no change required