View Issue Details

IDProjectCategoryView StatusLast Update
0001231XdebugUsage problems (Wrong Results)public2016-02-11 18:52
ReportermumuAssigned Toderick 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
Platformx64OSWindowsOS Version10
Product Version2.4.0rc2 
Target VersionFixed in Version 
Summary0001231: Crash while trying to debug
DescriptionCrash while trying to debug using phpStorm 10.0.2 on PHP 7.0.0 RTM x64 VC14 / Apache / fcgi.

Faulting application name: php-cgi.exe, version: 7.0.0.0, time stamp: 0x56607cf4
Faulting module name: php_xdebug-2.4.0rc2-7.0-vc14-nts-x86_64.dll, version: 2.4.0.5, time stamp: 0x565f896f
Exception code: 0xc0000005
Fault offset: 0x000000000001ee70
Faulting process id: 0x326c
Faulting application start time: 0x01d134391c869a9e
Faulting application path: D:\PF\php7\php-cgi.exe
Faulting module path: D:\PF\PHP7\ext\php_xdebug-2.4.0rc2-7.0-vc14-nts-x86_64.dll
Report Id: 3106d03d-0089-465a-82fa-c803e1f64f0e
Faulting package full name:
Faulting package-relative application ID:
TagsPHP7, windows
Operating System
PHP Version7.0.0-7.0.4

Activities

derick

2015-12-11 17:55

administrator   ~0003322

Can you please provide me with a method on how this can be reproduced? Just stating a Windows version is not useful.

mumu

2015-12-11 20:40

reporter   ~0003324

Last edited: 2015-12-11 20:40

View 2 revisions

I think I have used Step Over over this line:
        if ((!$this->data || !array_key_exists('usedAmountBase_CZK', $this->data)) && !array_key_exists('usedAmountBase_CZK', $data)) {

$this->data was null, $data was an array.

derick

2015-12-12 21:31

administrator   ~0003327

I just released Xdebug 2.4.0RC3, which hopefully addresses stability issues on Windows: http://xdebug.org/#2015_12_12 — Can you please try that? Make also sure you run this with PHP 7.0.0 (or later), and not a PHP 7 Release Candidate.

In case it does not solve the problem, please provide a *full* but *short* reproducible test case that I can run myself. That includes hopefully a *single* script, and an accompanying remote debugging log (which you can make by setting xdebug.remote_log=c:\windows\temp\xdebug.log in php.ini).

derick

2016-02-11 18:51

administrator   ~0003483

I can't reproduce this, and the requested feedback was not provided. I am closing this, but feel free to reopen if you can provide the requested information and the problem still occurs with Xdebug 2.4.0RC4.

Issue History

Date Modified Username Field Change
2015-12-11 17:46 mumu New Issue
2015-12-11 17:48 mumu Tag Attached: PHP7
2015-12-11 17:48 mumu Tag Attached: windows
2015-12-11 17:55 derick Note Added: 0003322
2015-12-11 17:55 derick Assigned To => derick
2015-12-11 17:55 derick Status new => feedback
2015-12-11 20:40 mumu Note Added: 0003324
2015-12-11 20:40 mumu Status feedback => assigned
2015-12-11 20:40 mumu Note Edited: 0003324 View Revisions
2015-12-12 21:31 derick PHP Version 7.0.0rc7 => 7.0.0-7.0.4
2015-12-12 21:31 derick Note Added: 0003327
2015-12-12 21:31 derick Status assigned => feedback
2016-02-11 18:51 derick Note Added: 0003483
2016-02-11 18:51 derick Status feedback => resolved
2016-02-11 18:51 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)