View Issue Details

IDProjectCategoryView StatusLast Update
0001238XdebugUsage problems (Wrong Results)public2016-01-25 21:59
ReporterpetervanderdoesAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version15.10
Product Version2.4.0rc3 
Target VersionFixed in Version2.4.0rc4 
Summary0001238: php-fpm7.0 crashed with SIGSEGV in xdebug_var_export()
DescriptionUsing a WordPress site, PHP 7 crashes always, while debugging and while not debugging, at a certain point in the code.
Taking this code out and checking it by itself does not produce the problem.
Steps To ReproduceHard to reproduce by others, it seems to specific to a certain site I have locally. Another WordPress site does not show the same problem. But the crash always occurs at the same point.
Additional InformationThe code that cause the crash:
function is_admin() {
    if ( isset( $GLOBALS['current_screen'] ) )
        return $GLOBALS['current_screen']->in_admin();
    elseif ( defined( 'WP_ADMIN' ) )
        return WP_ADMIN;

    return false;
}

It crashes on return WP_ADMIN;

Attached is the SegvAnalysis portion of the coredump.
TagsNo tags attached.
Operating System
PHP Version7.0.0-7.0.4

Activities

petervanderdoes

2015-12-18 16:31

reporter  

SegvAnalysis.txt (19,836 bytes)
SegvAnalysis:
 Segfault happened at: 0x7f958acebbe2 <xdebug_var_export+338>:	movzbl 0x8(%rax),%ecx
 PC (0x7f958acebbe2) ok
 source "0x8(%rax)" (0x00000012) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
SourcePackage: php7.0
Stacktrace:
 #0  0x00007f958acebbe2 in xdebug_var_export (struc=0x7ffff1d8b788, struc@entry=0x7ffff1d8b848, str=str@entry=0x7ffff1d8b8b0, level=level@entry=3, debug_zval=debug_zval@entry=0, options=options@entry=0x21e6a10) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1005
         tmpz = 0xa
         myht = <optimized out>
         tmp_str = <optimized out>
         is_temp = 0
         num = <optimized out>
         key = <optimized out>
         val = <optimized out>
 #1  0x00007f958acec034 in xdebug_array_element_export (options=0x21e6a10, debug_zval=0, str=0x7ffff1d8b8b0, level=1, hash_key=<optimized out>, index=<optimized out>, zv_nptr=0x7f957f7f0040) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:928
         zv = 0x7ffff1d8b848
 #2  xdebug_var_export (struc=<optimized out>, struc@entry=0x7ffff1d8b8a8, str=str@entry=0x7ffff1d8b8b0, level=level@entry=1, debug_zval=debug_zval@entry=0, options=options@entry=0x21e6a10) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1076
         _z = <optimized out>
         _p = 0x7f957f7f0040
         _end = 0x7f957f7f01e0
         myht = 0x7f958b4b1150
         tmp_str = <optimized out>
         is_temp = 0
         num = <optimized out>
         key = <optimized out>
         val = <optimized out>
 #3  0x00007f958acec567 in xdebug_get_zval_value (val=0x7f958b4155b0, debug_zval=debug_zval@entry=0, options=0x21e6a10, options@entry=0x0) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1168
         str = {l = 420, a = 1031, d = 0x22ce2e0 "array ('index.php' => array (0 => array (...), 10 => array (...)), 'upload.php' => array (5 => array (...), 10 => array (...)), 'link-manager.php' => array (5 => array (...), 10 => array (...), 15 => "...}
         default_options = 1
 #4  0x00007f958ace449a in xdebug_log_stack (error_type_str=<optimized out>, buffer=<optimized out>, error_filename=<optimized out>, error_lineno=<optimized out>) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_stack.c:223
         tmp_varname = 0x2302a20 "\020/?\002"
         tmp_value = <optimized out>
         c = 1
         variadic_opened = 0
         j = 1
         tmp_name = <optimized out>
         log_buffer = {l = 8236, a = 10263, d = 0x23fe3f0 "PHP   4. _wp_menu_output($menu = array (0 => array (0 => 'Dashboard', 1 => 'read', 2 => 'index.php', 3 => '', 4 => 'menu-top menu-top-first menu-icon-dashboard menu-top-first', 5 => 'menu-dashboard', "...}
         le = 0x21f0f00
         i = 0x23cc450
         error_type_str = <optimized out>
         buffer = <optimized out>
         error_filename = <optimized out>
         error_lineno = <optimized out>
         tmp_log_message = <optimized out>
 #5  0x00007f958ace6f57 in xdebug_error_cb (type=1024, error_filename=0x7f9581862b58 "/d3/sites/avirtualhome.com/htdocs/blog/wp/wp-includes/functions.php", error_lineno=3732, format=<optimized out>, args=<optimized out>) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_stack.c:759
         buffer = 0x7f957f0da480 "has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead."
         error_type_str = 0x2303010 "Notice"
         buffer_len = 184
         extra_brk_info = 0x0
         error_handling = <optimized out>
 #6  0x000000000047251f in zend_error_noreturn ()
 No symbol table info available.
 #7  0x00000000007a2134 in ?? ()
 No symbol table info available.
 #8  0x0000000000778f9a in dtrace_execute_internal ()
 No symbol table info available.
 #9  0x00007f958acd349e in xdebug_execute_internal (current_execute_data=0x7f958b4170d0, return_value=0x7f958b417030) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:2016
         edata = <optimized out>
         fse = 0x21eb180
         do_return = 0
         function_nr = 94979
         restore_error_handler_situation = 0
         tmp_error_cb = <optimized out>
 #10 0x000000000080c0d0 in ?? ()
 No symbol table info available.
 #11 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #12 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #13 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b416f20) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f95819015a8
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x23f4f90
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 94969
         le = <optimized out>
 #14 0x000000000080c20d in ?? ()
 No symbol table info available.
 #15 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #16 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #17 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b416cc0) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f9581700018
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x21e6fc0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 94962
         le = <optimized out>
 #18 0x000000000080c20d in ?? ()
 No symbol table info available.
 #19 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #20 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #21 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b416b80) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f9581647a28
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x21ebc10
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 94956
         le = <optimized out>
 #22 0x000000000080c20d in ?? ()
 No symbol table info available.
 #23 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #24 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #25 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b415540) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f957f026bd0
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x23cc450
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 89638
         le = <optimized out>
 #26 0x000000000080c20d in ?? ()
 No symbol table info available.
 #27 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #28 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #29 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b415350) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f958b480460
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x23f4640
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 89607
         le = <optimized out>
 #30 0x0000000000818a2c in ?? ()
 No symbol table info available.
 #31 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #32 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #33 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b4149b0) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f957f3ff700
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x24798d0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 82035
         le = <optimized out>
 #34 0x000000000081840c in ?? ()
 No symbol table info available.
 #35 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #36 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #37 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b414030) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f958b4802a0
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x23a2ca0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 0
         le = <optimized out>
 #38 0x000000000081b637 in zend_execute ()
 No symbol table info available.
 #39 0x0000000000789083 in zend_execute_scripts ()
 No symbol table info available.
 #40 0x00000000007297e0 in php_execute_script ()
 No symbol table info available.
 #41 0x0000000000475830 in main ()
 No symbol table info available.
StacktraceAddressSignature: /usr/sbin/php-fpm7.0:11:/usr/lib/php/20151012/xdebug.so+26be2:/usr/lib/php/20151012/xdebug.so+27034:/usr/lib/php/20151012/xdebug.so+27567:/usr/lib/php/20151012/xdebug.so+1f49a:/usr/lib/php/20151012/xdebug.so+21f57:/usr/sbin/php-fpm7.0+7251f:/usr/sbin/php-fpm7.0+3a2134:/usr/sbin/php-fpm7.0+378f9a:/usr/lib/php/20151012/xdebug.so+e49e:/usr/sbin/php-fpm7.0+40c0d0:/usr/sbin/php-fpm7.0+3c868b:/usr/sbin/php-fpm7.0+378e31:/usr/lib/php/20151012/xdebug.so+db0f:/usr/sbin/php-fpm7.0+40c20d:/usr/sbin/php-fpm7.0+3c868b
StacktraceTop:
 xdebug_var_export (struc=0x7ffff1d8b788, struc@entry=0x7ffff1d8b848, str=str@entry=0x7ffff1d8b8b0, level=level@entry=3, debug_zval=debug_zval@entry=0, options=options@entry=0x21e6a10) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1005
 xdebug_array_element_export (options=0x21e6a10, debug_zval=0, str=0x7ffff1d8b8b0, level=1, hash_key=<optimized out>, index=<optimized out>, zv_nptr=0x7f957f7f0040) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:928
 xdebug_var_export (struc=<optimized out>, struc@entry=0x7ffff1d8b8a8, str=str@entry=0x7ffff1d8b8b0, level=level@entry=1, debug_zval=debug_zval@entry=0, options=options@entry=0x21e6a10) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1076
 xdebug_get_zval_value (val=0x7f958b4155b0, debug_zval=debug_zval@entry=0, options=0x21e6a10, options@entry=0x0) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1168
 xdebug_log_stack (error_type_str=<optimized out>, buffer=<optimized out>, error_filename=<optimized out>, error_lineno=<optimized out>) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_stack.c:223
Tags: wily third-party-packages
ThreadStacktrace:
 .
 Thread 1 (Thread 0x7f959195b7c0 (LWP 20506)):
 #0  0x00007f958acebbe2 in xdebug_var_export (struc=0x7ffff1d8b788, struc@entry=0x7ffff1d8b848, str=str@entry=0x7ffff1d8b8b0, level=level@entry=3, debug_zval=debug_zval@entry=0, options=options@entry=0x21e6a10) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1005
         tmpz = 0xa
         myht = <optimized out>
         tmp_str = <optimized out>
         is_temp = 0
         num = <optimized out>
         key = <optimized out>
         val = <optimized out>
 #1  0x00007f958acec034 in xdebug_array_element_export (options=0x21e6a10, debug_zval=0, str=0x7ffff1d8b8b0, level=1, hash_key=<optimized out>, index=<optimized out>, zv_nptr=0x7f957f7f0040) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:928
         zv = 0x7ffff1d8b848
 #2  xdebug_var_export (struc=<optimized out>, struc@entry=0x7ffff1d8b8a8, str=str@entry=0x7ffff1d8b8b0, level=level@entry=1, debug_zval=debug_zval@entry=0, options=options@entry=0x21e6a10) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1076
         _z = <optimized out>
         _p = 0x7f957f7f0040
         _end = 0x7f957f7f01e0
         myht = 0x7f958b4b1150
         tmp_str = <optimized out>
         is_temp = 0
         num = <optimized out>
         key = <optimized out>
         val = <optimized out>
 #3  0x00007f958acec567 in xdebug_get_zval_value (val=0x7f958b4155b0, debug_zval=debug_zval@entry=0, options=0x21e6a10, options@entry=0x0) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_var.c:1168
         str = {l = 420, a = 1031, d = 0x22ce2e0 "array ('index.php' => array (0 => array (...), 10 => array (...)), 'upload.php' => array (5 => array (...), 10 => array (...)), 'link-manager.php' => array (5 => array (...), 10 => array (...), 15 => "...}
         default_options = 1
 #4  0x00007f958ace449a in xdebug_log_stack (error_type_str=<optimized out>, buffer=<optimized out>, error_filename=<optimized out>, error_lineno=<optimized out>) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_stack.c:223
         tmp_varname = 0x2302a20 "\020/?\002"
         tmp_value = <optimized out>
         c = 1
         variadic_opened = 0
         j = 1
         tmp_name = <optimized out>
         log_buffer = {l = 8236, a = 10263, d = 0x23fe3f0 "PHP   4. _wp_menu_output($menu = array (0 => array (0 => 'Dashboard', 1 => 'read', 2 => 'index.php', 3 => '', 4 => 'menu-top menu-top-first menu-icon-dashboard menu-top-first', 5 => 'menu-dashboard', "...}
         le = 0x21f0f00
         i = 0x23cc450
         error_type_str = <optimized out>
         buffer = <optimized out>
         error_filename = <optimized out>
         error_lineno = <optimized out>
         tmp_log_message = <optimized out>
 #5  0x00007f958ace6f57 in xdebug_error_cb (type=1024, error_filename=0x7f9581862b58 "/d3/sites/avirtualhome.com/htdocs/blog/wp/wp-includes/functions.php", error_lineno=3732, format=<optimized out>, args=<optimized out>) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug_stack.c:759
         buffer = 0x7f957f0da480 "has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead."
         error_type_str = 0x2303010 "Notice"
         buffer_len = 184
         extra_brk_info = 0x0
         error_handling = <optimized out>
 #6  0x000000000047251f in zend_error_noreturn ()
 No symbol table info available.
 #7  0x00000000007a2134 in ?? ()
 No symbol table info available.
 #8  0x0000000000778f9a in dtrace_execute_internal ()
 No symbol table info available.
 #9  0x00007f958acd349e in xdebug_execute_internal (current_execute_data=0x7f958b4170d0, return_value=0x7f958b417030) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:2016
         edata = <optimized out>
         fse = 0x21eb180
         do_return = 0
         function_nr = 94979
         restore_error_handler_situation = 0
         tmp_error_cb = <optimized out>
 #10 0x000000000080c0d0 in ?? ()
 No symbol table info available.
 #11 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #12 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #13 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b416f20) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f95819015a8
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x23f4f90
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 94969
         le = <optimized out>
 #14 0x000000000080c20d in ?? ()
 No symbol table info available.
 #15 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #16 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #17 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b416cc0) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f9581700018
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x21e6fc0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 94962
         le = <optimized out>
 #18 0x000000000080c20d in ?? ()
 No symbol table info available.
 #19 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #20 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #21 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b416b80) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f9581647a28
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x21ebc10
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 94956
         le = <optimized out>
 #22 0x000000000080c20d in ?? ()
 No symbol table info available.
 #23 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #24 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #25 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b415540) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f957f026bd0
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x23cc450
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 89638
         le = <optimized out>
 #26 0x000000000080c20d in ?? ()
 No symbol table info available.
 #27 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #28 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #29 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b415350) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f958b480460
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x23f4640
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 89607
         le = <optimized out>
 #30 0x0000000000818a2c in ?? ()
 No symbol table info available.
 #31 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #32 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #33 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b4149b0) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f957f3ff700
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x24798d0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 82035
         le = <optimized out>
 #34 0x000000000081840c in ?? ()
 No symbol table info available.
 #35 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #36 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #37 0x00007f958acd2b0f in xdebug_execute_ex (execute_data=0x7f958b414030) at /build/xdebug-cGQvQT/xdebug-2.4.0~rc3/xdebug-2.4.0RC3/xdebug.c:1871
         op_array = 0x7f958b4802a0
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x23a2ca0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 0
         le = <optimized out>
 #38 0x000000000081b637 in zend_execute ()
 No symbol table info available.
 #39 0x0000000000789083 in zend_execute_scripts ()
 No symbol table info available.
 #40 0x00000000007297e0 in php_execute_script ()
 No symbol table info available.
 #41 0x0000000000475830 in main ()
 No symbol table info available.
SegvAnalysis.txt (19,836 bytes)

derick

2015-12-18 16:35

administrator   ~0003358

Thanks for the report and backtrace.

I am pretty sure that this is 0001229 - can you try the latest source from GitHub please?

cheers,
Derick

aramonc

2015-12-18 16:53

reporter   ~0003359

Last edited: 2015-12-18 16:54

View 2 revisions

Derick, I don't know if this helps, but I'm seeing a similar issue. Syslog reports

[ 5277.283602] php-fpm7.0[29262]: segfault at 12 ip 00007f4fd4d0c082 sp 00007ffde87616e0 error 4 in xdebug.so[7f4fd4ce3000+38000]

I can provide full crash report if you like.

Environmnet:

Ubuntu 15.10
PHP 7.0.1 - Ondrej Sury PPA
XDebug 2.4.0 RC3 - Ondrej Sury PPA
PHPStorm 10.0.1
App in Symfony 2.7

I'll try the mainline branch this weekend.

petervanderdoes

2015-12-18 18:27

reporter   ~0003360

Cloned the repository, installed 2.4.0RC4-dev, resulted in NO crash during normal work, but crash when debugging as soon as a breakpoint is hit and you continue the program.

Uploaded new backtrace.

petervanderdoes

2015-12-18 18:27

reporter  

SegvAnalysis2.txt (18,803 bytes)
SegvAnalysis:
 Segfault happened at: 0x7fe510eedae2 <xdebug_var_export_xml_node+194>: movzbl 0x8(%rcx),%eax
 PC (0x7fe510eedae2) ok
 source "0x8(%rcx)" (0x00000026) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
SourcePackage: php7.0
Stacktrace:
 #0  0x00007fe510eedae2 in xdebug_var_export_xml_node (struc=0x7ffcee5934c0, struc@entry=0x7ffcee593598, name=0x16ab600 "$GLOBALS['wp_registered_widget_updates']", node=node@entry=0x14ddcf0, options=options@entry=0x14d5b80, level=level@entry=1) at /d1/development/php/xdebug/xdebug_var.c:2079
         tmpz = 0x1e
         myht = <optimized out>
         class_name = <optimized out>
         class_name_len = <optimized out>
         num = <optimized out>
         key = <optimized out>
         z_val = <optimized out>
         xoi_val = <optimized out>
 #1  0x00007fe510eee2cc in xdebug_array_element_export_xml_node (options=0x14d5b80, parent_name=0x16aa340 "$GLOBALS", parent=0x16aa2e0, level=0, hash_key=<optimized out>, index=<optimized out>, zv_nptr=0x7fe505582680) at /d1/development/php/xdebug/xdebug_var.c:1878
         zv = 0x7ffcee593598
         node = 0x14ddcf0
         full_name = {l = 40, a = 1032, d = 0x16ab600 "$GLOBALS['wp_registered_widget_updates']"}
         name = 0x14ddd30 "wp_registered_widget_updates"
         name_len = <optimized out>
 #2  xdebug_var_export_xml_node (struc=<optimized out>, struc@entry=0x7ffcee593608, name=name@entry=0x16aa340 "$GLOBALS", node=node@entry=0x16aa2e0, options=options@entry=0x14d5b80, level=level@entry=0) at /d1/development/php/xdebug/xdebug_var.c:2140
         _z = <optimized out>
         _p = 0x7fe505582680
         _end = 0x7fe505583a60
         myht = 0xff3130 <executor_globals+304>
         class_name = <optimized out>
         class_name_len = <optimized out>
         num = <optimized out>
         key = <optimized out>
         z_val = <optimized out>
         xoi_val = <optimized out>
 #3  0x00007fe510eeeac5 in xdebug_get_zval_value_xml_node_ex (name=name@entry=0x7fe510ef3467 "GLOBALS", val=0x7fe505582c80, var_type=var_type@entry=0, options=options@entry=0x14d5b80) at /d1/development/php/xdebug/xdebug_var.c:2289
         node = 0x16aa2e0
         short_name = <optimized out>
         full_name = 0x16aa340 "$GLOBALS"
 #4  0x00007fe510edbbe2 in get_symbol (name=name@entry=0x7fe510ef3467 "GLOBALS", options=options@entry=0x14d5b80) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:280
         retval = <optimized out>
 #5  0x00007fe510ede51f in add_variable_node (node=node@entry=0x14dcc50, name=name@entry=0x7fe510ef3467 "GLOBALS", options=options@entry=0x14d5b80, no_eval=0, non_null=1, var_only=1) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:1324
         contents = <optimized out>
 #6  0x00007fe510ee0872 in attach_context_vars (func=0x7fe510edc920 <attach_used_var_with_contents>, depth=0, context_id=1, options=0x14d5b80, node=0x14dcc50) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:1713
         fse = <optimized out>
         var_name = 0x15257c0 ""
 #7  xdebug_dbgp_handle_context_get (retval=0x7ffcee593700, context=<optimized out>, args=<optimized out>) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:1892
         context_id = <optimized out>
         depth = 0
         options = 0x14d5b80
 #8  0x00007fe510edd7c7 in xdebug_dbgp_parse_option (flags=0, retval=0x14dcc50, line=0x16ba410 "context_get -i 20 -d 0 -c 1", context=0x7fe5110ffcc8 <xdebug_globals+808>) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:2148
         ret = 0
         cmd = <optimized out>
         res = 0
         args = <optimized out>
         error = <optimized out>
 #9  xdebug_dbgp_cmdloop (context=context@entry=0x7fe5110ffcc8 <xdebug_globals+808>, bail=bail@entry=1) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:2197
         option = 0x16ba410 "context_get -i 20 -d 0 -c 1"
         ret = 0
         response = 0x14dcc50
 #10 0x00007fe510ee16ed in xdebug_dbgp_breakpoint (context=0x7fe5110ffcc8 <xdebug_globals+808>, stack=<optimized out>, file=<optimized out>, lineno=376, type=<optimized out>, exception=0x0, code=0x0, message=0x0) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:2468
         response = 0x14dcc50
         error_container = 0x16a5c90
 #11 0x00007fe510ed208f in xdebug_statement_call (op_array=<optimized out>) at /d1/development/php/xdebug/xdebug.c:2619
         break_ok = <optimized out>
         old_error_reporting = <optimized out>
         retval = {value = {lval = 0, dval = 0, counted = 0x0, str = 0x0, arr = 0x0, obj = 0x0, res = 0x0, ref = 0x0, ast = 0x0, zv = 0x0, ptr = 0x0, ce = 0x0, func = 0x0, ww = {w1 = 0, w2 = 0}}, u1 = {v = {type = 0 '\000', type_flags = 145 '\221', const_flags = 97 'a', reserved = 17 '\021'}, type_info = 291606784}, u2 = {var_flags = 32741, next = 32741, cache_slot = 32741, lineno = 32741, num_args = 32741, fe_pos = 32741, fe_iter_idx = 32741}}
         le = <optimized out>
         brk = <optimized out>
         fse = <optimized out>
         lineno = 376
         file = 0x7fe5116709d8 "/d3/sites/avirtualhome.com/htdocs/blog/wp/wp-settings.php"
         level = <optimized out>
 #12 0x000000000077cf62 in zend_llist_apply_with_argument ()
 No symbol table info available.
 #13 0x000000000080db66 in ?? ()
 No symbol table info available.
 #14 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #15 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #16 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe511616fc0) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe511691540
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x1698850
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 62
         le = <optimized out>
 #17 0x0000000000818a2c in ?? ()
 No symbol table info available.
 #18 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #19 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #20 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe511616b40) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe511691460
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x1549100
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 19
         le = <optimized out>
 #21 0x000000000081840c in ?? ()
 No symbol table info available.
 #22 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #23 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #24 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe5116165c0) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe511691380
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x16b8be0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 9
         le = <optimized out>
 #25 0x000000000081840c in ?? ()
 No symbol table info available.
 #26 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #27 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #28 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe5116152b0) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe5116912a0
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x1337280
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 2
         le = <optimized out>
 #29 0x000000000081840c in ?? ()
 No symbol table info available.
 #30 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #31 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #32 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe511613030) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe5116910e0
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x144dae0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 0
         le = <optimized out>
 #33 0x000000000081b637 in zend_execute ()
 No symbol table info available.
 #34 0x0000000000789083 in zend_execute_scripts ()
 No symbol table info available.
 #35 0x00000000007297e0 in php_execute_script ()
 No symbol table info available.
 #36 0x0000000000475830 in main ()
 No symbol table info available.
StacktraceAddressSignature: /usr/sbin/php-fpm7.0:11:/usr/lib/php/20151012/xdebug.so+2aae2:/usr/lib/php/20151012/xdebug.so+2b2cc:/usr/lib/php/20151012/xdebug.so+2bac5:/usr/lib/php/20151012/xdebug.so+18be2:/usr/lib/php/20151012/xdebug.so+1b51f:/usr/lib/php/20151012/xdebug.so+1d872:/usr/lib/php/20151012/xdebug.so+1a7c7:/usr/lib/php/20151012/xdebug.so+1e6ed:/usr/lib/php/20151012/xdebug.so+f08f:/usr/sbin/php-fpm7.0+37cf62:/usr/sbin/php-fpm7.0+40db66:/usr/sbin/php-fpm7.0+3c868b:/usr/sbin/php-fpm7.0+378e31:/usr/lib/php/20151012/xdebug.so+f53f:/usr/sbin/php-fpm7.0+418a2c
StacktraceTop:
 xdebug_var_export_xml_node (struc=0x7ffcee5934c0, struc@entry=0x7ffcee593598, name=0x16ab600 "$GLOBALS['wp_registered_widget_updates']", node=node@entry=0x14ddcf0, options=options@entry=0x14d5b80, level=level@entry=1) at /d1/development/php/xdebug/xdebug_var.c:2079
 xdebug_array_element_export_xml_node (options=0x14d5b80, parent_name=0x16aa340 "$GLOBALS", parent=0x16aa2e0, level=0, hash_key=<optimized out>, index=<optimized out>, zv_nptr=0x7fe505582680) at /d1/development/php/xdebug/xdebug_var.c:1878
 xdebug_var_export_xml_node (struc=<optimized out>, struc@entry=0x7ffcee593608, name=name@entry=0x16aa340 "$GLOBALS", node=node@entry=0x16aa2e0, options=options@entry=0x14d5b80, level=level@entry=0) at /d1/development/php/xdebug/xdebug_var.c:2140
 xdebug_get_zval_value_xml_node_ex (name=name@entry=0x7fe510ef3467 "GLOBALS", val=0x7fe505582c80, var_type=var_type@entry=0, options=options@entry=0x14d5b80) at /d1/development/php/xdebug/xdebug_var.c:2289
 get_symbol (name=name@entry=0x7fe510ef3467 "GLOBALS", options=options@entry=0x14d5b80) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:280
Tags: wily third-party-packages
ThreadStacktrace:
 .
 Thread 1 (Thread 0x7fe517c387c0 (LWP 30170)):
 #0  0x00007fe510eedae2 in xdebug_var_export_xml_node (struc=0x7ffcee5934c0, struc@entry=0x7ffcee593598, name=0x16ab600 "$GLOBALS['wp_registered_widget_updates']", node=node@entry=0x14ddcf0, options=options@entry=0x14d5b80, level=level@entry=1) at /d1/development/php/xdebug/xdebug_var.c:2079
         tmpz = 0x1e
         myht = <optimized out>
         class_name = <optimized out>
         class_name_len = <optimized out>
         num = <optimized out>
         key = <optimized out>
         z_val = <optimized out>
         xoi_val = <optimized out>
 #1  0x00007fe510eee2cc in xdebug_array_element_export_xml_node (options=0x14d5b80, parent_name=0x16aa340 "$GLOBALS", parent=0x16aa2e0, level=0, hash_key=<optimized out>, index=<optimized out>, zv_nptr=0x7fe505582680) at /d1/development/php/xdebug/xdebug_var.c:1878
         zv = 0x7ffcee593598
         node = 0x14ddcf0
         full_name = {l = 40, a = 1032, d = 0x16ab600 "$GLOBALS['wp_registered_widget_updates']"}
         name = 0x14ddd30 "wp_registered_widget_updates"
         name_len = <optimized out>
 #2  xdebug_var_export_xml_node (struc=<optimized out>, struc@entry=0x7ffcee593608, name=name@entry=0x16aa340 "$GLOBALS", node=node@entry=0x16aa2e0, options=options@entry=0x14d5b80, level=level@entry=0) at /d1/development/php/xdebug/xdebug_var.c:2140
         _z = <optimized out>
         _p = 0x7fe505582680
         _end = 0x7fe505583a60
         myht = 0xff3130 <executor_globals+304>
         class_name = <optimized out>
         class_name_len = <optimized out>
         num = <optimized out>
         key = <optimized out>
         z_val = <optimized out>
         xoi_val = <optimized out>
 #3  0x00007fe510eeeac5 in xdebug_get_zval_value_xml_node_ex (name=name@entry=0x7fe510ef3467 "GLOBALS", val=0x7fe505582c80, var_type=var_type@entry=0, options=options@entry=0x14d5b80) at /d1/development/php/xdebug/xdebug_var.c:2289
         node = 0x16aa2e0
         short_name = <optimized out>
         full_name = 0x16aa340 "$GLOBALS"
 #4  0x00007fe510edbbe2 in get_symbol (name=name@entry=0x7fe510ef3467 "GLOBALS", options=options@entry=0x14d5b80) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:280
         retval = <optimized out>
 #5  0x00007fe510ede51f in add_variable_node (node=node@entry=0x14dcc50, name=name@entry=0x7fe510ef3467 "GLOBALS", options=options@entry=0x14d5b80, no_eval=0, non_null=1, var_only=1) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:1324
         contents = <optimized out>
 #6  0x00007fe510ee0872 in attach_context_vars (func=0x7fe510edc920 <attach_used_var_with_contents>, depth=0, context_id=1, options=0x14d5b80, node=0x14dcc50) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:1713
         fse = <optimized out>
         var_name = 0x15257c0 ""
 #7  xdebug_dbgp_handle_context_get (retval=0x7ffcee593700, context=<optimized out>, args=<optimized out>) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:1892
         context_id = <optimized out>
         depth = 0
         options = 0x14d5b80
 #8  0x00007fe510edd7c7 in xdebug_dbgp_parse_option (flags=0, retval=0x14dcc50, line=0x16ba410 "context_get -i 20 -d 0 -c 1", context=0x7fe5110ffcc8 <xdebug_globals+808>) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:2148
         ret = 0
         cmd = <optimized out>
         res = 0
         args = <optimized out>
         error = <optimized out>
 #9  xdebug_dbgp_cmdloop (context=context@entry=0x7fe5110ffcc8 <xdebug_globals+808>, bail=bail@entry=1) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:2197
         option = 0x16ba410 "context_get -i 20 -d 0 -c 1"
         ret = 0
         response = 0x14dcc50
 #10 0x00007fe510ee16ed in xdebug_dbgp_breakpoint (context=0x7fe5110ffcc8 <xdebug_globals+808>, stack=<optimized out>, file=<optimized out>, lineno=376, type=<optimized out>, exception=0x0, code=0x0, message=0x0) at /d1/development/php/xdebug/xdebug_handler_dbgp.c:2468
         response = 0x14dcc50
         error_container = 0x16a5c90
 #11 0x00007fe510ed208f in xdebug_statement_call (op_array=<optimized out>) at /d1/development/php/xdebug/xdebug.c:2619
         break_ok = <optimized out>
         old_error_reporting = <optimized out>
         retval = {value = {lval = 0, dval = 0, counted = 0x0, str = 0x0, arr = 0x0, obj = 0x0, res = 0x0, ref = 0x0, ast = 0x0, zv = 0x0, ptr = 0x0, ce = 0x0, func = 0x0, ww = {w1 = 0, w2 = 0}}, u1 = {v = {type = 0 '\000', type_flags = 145 '\221', const_flags = 97 'a', reserved = 17 '\021'}, type_info = 291606784}, u2 = {var_flags = 32741, next = 32741, cache_slot = 32741, lineno = 32741, num_args = 32741, fe_pos = 32741, fe_iter_idx = 32741}}
         le = <optimized out>
         brk = <optimized out>
         fse = <optimized out>
         lineno = 376
         file = 0x7fe5116709d8 "/d3/sites/avirtualhome.com/htdocs/blog/wp/wp-settings.php"
         level = <optimized out>
 #12 0x000000000077cf62 in zend_llist_apply_with_argument ()
 No symbol table info available.
 #13 0x000000000080db66 in ?? ()
 No symbol table info available.
 #14 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #15 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #16 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe511616fc0) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe511691540
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x1698850
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 62
         le = <optimized out>
 #17 0x0000000000818a2c in ?? ()
 No symbol table info available.
 #18 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #19 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #20 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe511616b40) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe511691460
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x1549100
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 19
         le = <optimized out>
 #21 0x000000000081840c in ?? ()
 No symbol table info available.
 #22 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #23 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #24 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe5116165c0) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe511691380
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x16b8be0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 9
         le = <optimized out>
 #25 0x000000000081840c in ?? ()
 No symbol table info available.
 #26 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #27 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #28 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe5116152b0) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe5116912a0
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x1337280
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 2
         le = <optimized out>
 #29 0x000000000081840c in ?? ()
 No symbol table info available.
 #30 0x00000000007c868b in execute_ex ()
 No symbol table info available.
 #31 0x0000000000778e31 in dtrace_execute_ex ()
 No symbol table info available.
 #32 0x00007fe510ed253f in xdebug_execute_ex (execute_data=0x7fe511613030) at /d1/development/php/xdebug/xdebug.c:1874
         op_array = 0x7fe5116910e0
         edata = <optimized out>
         dummy = <optimized out>
         fse = 0x144dae0
         xfse = <optimized out>
         magic_cookie = <optimized out>
         do_return = 0
         function_nr = 0
         le = <optimized out>
 #33 0x000000000081b637 in zend_execute ()
 No symbol table info available.
 #34 0x0000000000789083 in zend_execute_scripts ()
 No symbol table info available.
 #35 0x00000000007297e0 in php_execute_script ()
 No symbol table info available.
 #36 0x0000000000475830 in main ()
 No symbol table info available.
SegvAnalysis2.txt (18,803 bytes)

derick

2015-12-18 18:39

administrator   ~0003361

Looks like I missed one occurence of the issue.

Quick fix for you to make things work while I fix it is to change any -O2 to -O0 in the Makefile after running "./configure" and before "make". Instead of just "make" you'll likely will have to run "make clean" first (but still after "./configure".

petervanderdoes

2015-12-18 19:04

reporter   ~0003362

Yup that seems to solve the issue for debugging.

Thanks.

petervanderdoes

2015-12-18 19:04

reporter   ~0003363

And regular stuff as well, No more crashing

derick

2015-12-18 23:16

administrator   ~0003364

This should now be fixed in Git's master - without the O2 ? O0 hack.

Issue History

Date Modified Username Field Change
2015-12-18 16:31 petervanderdoes New Issue
2015-12-18 16:31 petervanderdoes File Added: SegvAnalysis.txt
2015-12-18 16:35 derick Note Added: 0003358
2015-12-18 16:35 derick Assigned To => derick
2015-12-18 16:35 derick Status new => feedback
2015-12-18 16:53 aramonc Note Added: 0003359
2015-12-18 16:54 aramonc Note Edited: 0003359 View Revisions
2015-12-18 18:27 petervanderdoes Note Added: 0003360
2015-12-18 18:27 petervanderdoes Status feedback => assigned
2015-12-18 18:27 petervanderdoes File Added: SegvAnalysis2.txt
2015-12-18 18:39 derick Note Added: 0003361
2015-12-18 19:04 petervanderdoes Note Added: 0003362
2015-12-18 19:04 petervanderdoes Note Added: 0003363
2015-12-18 23:16 derick Note Added: 0003364
2015-12-18 23:16 derick Status assigned => closed
2015-12-18 23:16 derick Resolution open => fixed
2015-12-18 23:16 derick Fixed in Version => 2.4.0
2016-01-25 21:59 derick Fixed in Version 2.4.0 => 2.4.0rc4
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)