View Issue Details

IDProjectCategoryView StatusLast Update
0001248Xdebug(No Category)public2016-01-25 21:59
ReporterDevDonkeyAssigned Toderick 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformOSUbuntuOS Version15.10
Product Version2.4.0rc3 
Target VersionFixed in Version2.4.0rc4 
Summary0001248: Fails to show variables while paused at breakpoint
DescriptionUsing PHPStorm 10.0.3 and Chromium

Debugging in PHPStorm successfully catches the breakpoints in the code, but no variables are displayed in the console. Instead, 'collecting information' is displayed with the occasional 'flicker' of the variables appearing for a fraction of a second.

This is only happening on PHP7.0.2. All fine with PHP5.6.15, PHP7.0.1.

Ive also tried using RC2 and the same problem exists.
Steps To ReproducePHP Remote Debug configuration
set breakpoint
start debug session
refresh browser
Additional Informationxdebug php.ini config:

[xdebug]
zend_extension="/home/matt/php_modules/20151012/xdebug.so"
xdebug.remote_enable=1
xdebug.remote_port="9009"
xdebug.profiler_enable=0
xdebug.remote_connect_back=0
xdebug.remote_cookie_expire_time=0
xdebug.remote_autostart=0
xdebug.profiler_output_dir="/tmp"
xdebug.idekey="PHPSTORM"
TagsNo tags attached.
Operating SystemUbuntu 15.10
PHP Version7.0.0-7.0.4

Activities

derick

2016-01-12 13:54

administrator   ~0003412

What's in your xdebug.log file? (You can make one with xdebug.remote_log=/tmp/xdebug.log in php.ini)

DevDonkey

2016-01-12 14:21

reporter  

xdebug.log (162,231 bytes)

DevDonkey

2016-01-12 14:22

reporter   ~0003413

Last edited: 2016-01-12 15:05

View 2 revisions

I thought it better to upload the whole log file. This a fresh file with just one break point stop in it.

edit: oddly I've just recompiled php7.0.0 as a workaround and it's doing the same thing. I've tried rolling myself back to xdebugRC2 and Im still getting the same problem.

Because of this Im wondering if I have some config issue as I know I had RC2 and 7.0.0 running very happily before.

DevDonkey

2016-01-13 10:43

reporter   ~0003418

after a twitter message from JetBrains they seem to think this is their bug. ive raised a ticket with them. will post the outcome.

DevDonkey

2016-01-15 15:02

reporter   ~0003420

Hiya, just an update. Ive been through some hoops with Jetbrains and can confirm that PHPstorm is working correctly so have suggested its an xdebug issue. Interestingly, during some tests, very simple code (1 liners), xdebug behaves as expected. However, when debugging my symfony2.8 app is when the crash occurs.

Ive attached an xdebug log of the latest failure.

DevDonkey

2016-01-15 15:04

reporter  

xdebug.1.log (218,456 bytes)

DevDonkey

2016-01-18 16:51

reporter   ~0003422

I've just compiled RC4-dev and I no longer have the problem.

derick

2016-01-19 22:33

administrator   ~0003426

That's good to hear - thanks for checking. I'll likely release RC4 in the next few days. When that comes out, could you be so kind to try again and confirm it is indeed fixed?

cheers,
Derick

Issue History

Date Modified Username Field Change
2016-01-12 13:42 DevDonkey New Issue
2016-01-12 13:54 derick Note Added: 0003412
2016-01-12 13:54 derick Assigned To => derick
2016-01-12 13:54 derick Status new => feedback
2016-01-12 14:21 DevDonkey File Added: xdebug.log
2016-01-12 14:22 DevDonkey Note Added: 0003413
2016-01-12 14:22 DevDonkey Status feedback => assigned
2016-01-12 15:05 DevDonkey Note Edited: 0003413 View Revisions
2016-01-13 10:43 DevDonkey Note Added: 0003418
2016-01-15 15:02 DevDonkey Note Added: 0003420
2016-01-15 15:04 DevDonkey File Added: xdebug.1.log
2016-01-18 16:51 DevDonkey Note Added: 0003422
2016-01-19 22:33 derick Note Added: 0003426
2016-01-19 22:33 derick Status assigned => resolved
2016-01-19 22:33 derick Fixed in Version => 2.4.0
2016-01-19 22:33 derick Resolution open => no change required
2016-01-25 21:59 derick Fixed in Version 2.4.0 => 2.4.0rc4
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)