View Issue Details

IDProjectCategoryView StatusLast Update
0001265XdebugUsage problems (Wrong Results)public2016-12-04 15:19
Reporterexx8Assigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformWAMPOSwindowsOS Version10
Product Version2.4.0rc4 
Target VersionFixed in Version 
Summary0001265: xdebug crashes after ::__set_state();
DescriptionIt seems that xdebug crashes after stdClass::__set_state(); and won't let you keep monitoring the break points.
Though in the example it's shown only with stdClass, it's true to every class in php
Additional Informationexample:
stdClass::__set_state();//after this line you won't be able to have a break point that actually stops the code
stdClass::__set_state();
TagsNo tags attached.
Operating System
PHP Version5.5.10-5.5.14

Activities

derick

2016-02-08 19:02

administrator   ~0003446

Please refer to https://xdebug.org/support.php#remote for information on how to submit bugs related to remote debugging. This URL explains which information I require to debug this.

exx8

2016-02-09 18:10

reporter  

xdebug.logs (5,320 bytes)

exx8

2016-02-09 18:11

reporter   ~0003470

I added logs, here is the script:
<?php
class A{}
$b=A::__set_state();
var_dump($b);

break points were added along the code.

derick

2016-02-09 18:30

administrator   ~0003471

Thanks for that!

The logs don't show the setting of any breakpoints, or stepping through code at all. Do you actually step through the code with your IDE?

When I run the code without any extensions loaded, all I am getting is the following:

    Fatal error: Call to undefined method A::__set_state() in - on line 3

Which makes sense, as the A class does not have __set_state() defined.

The logs do however show that you are using PHP version 5.5.0-dev, which sounds like a pre-release version of something.

derick

2016-02-27 15:59

administrator   ~0003526

Ping?

derick

2016-12-04 15:19

administrator   ~0003901

Can't reproduce, and the requested information was not supplied. Please reopen this issue if the problem persists.

Issue History

Date Modified Username Field Change
2016-02-05 16:36 exx8 New Issue
2016-02-08 19:02 derick Note Added: 0003446
2016-02-08 19:02 derick Assigned To => derick
2016-02-08 19:02 derick Status new => feedback
2016-02-09 18:10 exx8 File Added: xdebug.logs
2016-02-09 18:11 exx8 Note Added: 0003470
2016-02-09 18:11 exx8 Status feedback => assigned
2016-02-09 18:30 derick Note Added: 0003471
2016-02-09 18:30 derick Status assigned => feedback
2016-02-27 15:59 derick Note Added: 0003526
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-04 15:19 derick Note Added: 0003901
2016-12-04 15:19 derick Status feedback => resolved
2016-12-04 15:19 derick Resolution open => unable to reproduce