View Issue Details

IDProjectCategoryView StatusLast Update
0001276XdebugUsage problems (Wrong Results)public2017-01-03 18:45
ReporterdeepedAssigned Toderick 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformPhpOSWindows 7 x64OS Version7
Product Version2.4.0rc4 
Target VersionFixed in Version 
Summary0001276: Xdebug sometimes crashes
Descriptiondear Xdebug,

with an older version it didnt occur, but with the newest (2.4) version xdebug just crashes during execution. I mean apache crashes, no fatal error, or any output, browser sends "unable to load the page". Under the same circumstances, it happens 1 case of 5.
TagsNo tags attached.
Operating System
PHP Version5.6.0-5.6.4

Activities

deeped

2016-02-28 10:21

reporter   ~0003534

note: I updated to rc4. It has way lesser crashes :)

derick

2016-03-04 15:36

administrator   ~0003542

Can you try Xdebug 2.4.0 which got released yesterday too please? And if you disable opcache - does that change things?

deeped

2016-03-06 16:36

reporter   ~0003563

sadly it still crashes in rare occasions

derick

2016-12-04 15:30

administrator   ~0003903

Can you still reproduce this?

If so, I am going to need a small reproducible script - preferable something I can run from the command line, and without any dependencies.

If it crashes, I would like a GDB backtrace as is described at https://bugs.php.net/bugs-generating-backtrace.php

derick

2017-01-03 18:45

administrator   ~0004120

I could not reproduce this, as there was no reproducible case, and no additional information was presented. I am therefore closing this report.

Issue History

Date Modified Username Field Change
2016-02-27 16:19 deeped New Issue
2016-02-28 10:21 deeped Note Added: 0003534
2016-03-04 15:36 derick Note Added: 0003542
2016-03-04 15:36 derick Assigned To => derick
2016-03-04 15:36 derick Status new => feedback
2016-03-06 16:36 deeped Note Added: 0003563
2016-03-06 16:36 deeped Status feedback => assigned
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-04 15:30 derick Note Added: 0003903
2016-12-04 15:30 derick Status assigned => feedback
2017-01-03 18:45 derick Note Added: 0004120
2017-01-03 18:45 derick Status feedback => resolved
2017-01-03 18:45 derick Resolution open => fixed