View Issue Details

IDProjectCategoryView StatusLast Update
0001298XdebugFeature/Change requestpublic2016-12-11 23:50
ReporterPerson93Assigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.3.2 
Target VersionFixed in Version 
Summary0001298: Incomplete stack trace when re-throwing exception
DescriptionWhen an exception bubbles up and is re-thrown it displays a stack trace but it only shows the stack trace from the catch block where the exception is handled, it does not show the stack trace from where the exception was created.
Steps To ReproduceWrite a try catch block.
Call a function that throws an exception from the try block.
Throw the caught exception (not a new one, throw the one that was caught).
TagsNo tags attached.
Operating System
PHP Version5.5.10-5.5.14

Relationships

duplicate of 0000450 acknowledgedderick "Incomplete" backtraces when an exception gets rethrown 

Activities

derick

2016-12-11 23:50

administrator   ~0004014

This is a duplicate of 0000450.

Issue History

Date Modified Username Field Change
2016-05-03 17:51 Person93 New Issue
2016-12-11 23:50 derick Note Added: 0004014
2016-12-11 23:50 derick Relationship added duplicate of 0000450
2016-12-11 23:50 derick Status new => resolved
2016-12-11 23:50 derick Resolution open => duplicate
2016-12-11 23:50 derick Assigned To => derick